summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-07 00:16:57 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-07 01:00:11 +0200
commit96a4438238b1670fb083505125867b1c8085b286 (patch)
tree3b79642e1ff81cf67c7a14881aff5f966286c33d /xfce-base/thunar
parentdev-python/rope: Remove old (diff)
downloadgentoo-96a4438238b1670fb083505125867b1c8085b286.tar.gz
gentoo-96a4438238b1670fb083505125867b1c8085b286.tar.bz2
gentoo-96a4438238b1670fb083505125867b1c8085b286.zip
xfce-base/thunar: Bump to 4.16.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/thunar')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.16.7.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 28b584d6585c..bbe4f34129f7 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,3 @@
DIST thunar-4.16.6.tar.bz2 2435447 BLAKE2B 0ec50e8330643fc0c1881fa49ef1b8d0a90c8ef3ade3f7bb0756525381ec885137f808451db0eff52a0f51f337cf0de787dcb43544e52c832e8e94332345ea75 SHA512 2e9800935907477664d3a17bca5998266873a84423586f9e7ee3b7c6ba41314b372f7a6db5d9dd17f10af6405afafb808a78b8e8d07dbdfa8e00aa5fa9d3a552
+DIST thunar-4.16.7.tar.bz2 2427885 BLAKE2B ead71d045ebccf225e0d52d2d3531abdc63428e0f4463319aefc784ab052dfefd6887bc7cf946acc7976c86df0866d3873a3db68cb42054ef0d812f74bb76e95 SHA512 1b1ba2b78aef34aa87ea5a62c5715e94263463c2011cb073d58212529e300bef520079757d0f7550925ebc60183f0c9169ddb1f65098fd4d475187cef4cc3bd8
DIST thunar-4.17.1.tar.bz2 2461612 BLAKE2B 2afed1e57c3f81ba255a02c3d6092492292e143162c47813159fabca5a0891d7d089053fcbab8e0ec60436a94121828905bece8af2e1e91f5dc3884bf05703bb SHA512 e6f5e70679dafd91d992a950f90b21ef062c7e262443c496724b170baf409e74342dc56d7a046124c0ad00a827c9b1ca616d34c74b543a61316e236810e537af
diff --git a/xfce-base/thunar/thunar-4.16.7.ebuild b/xfce-base/thunar/thunar-4.16.7.ebuild
new file mode 100644
index 000000000000..a50b1046a411
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.16.7.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+DEPEND=">=dev-libs/glib-2.50
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-4.15.3:=
+ >=xfce-base/libxfce4ui-4.15.3:=
+ >=xfce-base/libxfce4util-4.15.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )"
+RDEPEND="${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}