summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-21 04:15:30 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-21 04:23:35 +0200
commit9f12df5274e7171331ed73bcc68031679f0793ea (patch)
treede2c955dd00bad8dd0aa4e8851bd81fe2f37fe42 /xfce-base/xfce4-appfinder/xfce4-appfinder-4.15.1.ebuild
parentxfce-base/exo: Bump to 4.15.2 (diff)
downloadgentoo-9f12df5274e7171331ed73bcc68031679f0793ea.tar.gz
gentoo-9f12df5274e7171331ed73bcc68031679f0793ea.tar.bz2
gentoo-9f12df5274e7171331ed73bcc68031679f0793ea.zip
xfce-base/xfce4-appfinder: Bump to 4.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfce4-appfinder/xfce4-appfinder-4.15.1.ebuild')
-rw-r--r--xfce-base/xfce4-appfinder/xfce4-appfinder-4.15.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-base/xfce4-appfinder/xfce4-appfinder-4.15.1.ebuild b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.15.1.ebuild
new file mode 100644
index 000000000000..f77a5531f4c6
--- /dev/null
+++ b/xfce-base/xfce4-appfinder/xfce4-appfinder-4.15.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop"
+HOMEPAGE="https://docs.xfce.org/xfce/xfce4-appfinder/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.42
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/garcon-0.3:=
+ >=xfce-base/libxfce4util-4.15.2:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/xfconf-4.10:=
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}