summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-20 19:54:41 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-20 19:54:41 +0200
commitb42807e75b84a3a373cd49f5f75f42bcfde7a7f4 (patch)
tree3a8921b85c9bb7f2cc9ba89b59b7697a7cde488b /xfce-base/xfce4-panel
parentnet-dns/pdns-recursor: Stabilize 4.7.1 on amd64/x86 (diff)
downloadgentoo-b42807e75b84a3a373cd49f5f75f42bcfde7a7f4.tar.gz
gentoo-b42807e75b84a3a373cd49f5f75f42bcfde7a7f4.tar.bz2
gentoo-b42807e75b84a3a373cd49f5f75f42bcfde7a7f4.zip
xfce-base/xfce4-panel: Bump to 4.17.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfce4-panel')
-rw-r--r--xfce-base/xfce4-panel/Manifest1
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.17.3.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/Manifest b/xfce-base/xfce4-panel/Manifest
index 48ddf770c5ce..693756cea677 100644
--- a/xfce-base/xfce4-panel/Manifest
+++ b/xfce-base/xfce4-panel/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-panel-4.16.4.tar.bz2 1383630 BLAKE2B e370fc286f5b035671e059e81a5c890842949c60a8aa1ae4cb06ded7f1e538d90bf633efd7e3e2b7642eb1b490a48eda3cabd1a967930cb63cd423fb5b807e22 SHA512 a1ad5a528968c4b1a5d2fb1537f7774aeeb525d7cb2f77e261b187b94e9de22f018bbd47d462ce4ad09b360126548d5848e46643df40549f9f8a3c44a4a14564
DIST xfce4-panel-4.17.2.tar.bz2 1408821 BLAKE2B db607dc1d35e746608ffe1484f2484589ae81d5d58387c8ae8c9fde9d9fdf0747f6746838290dcf1f6c9f6d1bb3efc130ec14445e6d48ac014bc114afe001f71 SHA512 a1d34d7ecdb196ba7095e613010e576daa809f0a94d48546a27731dc617a26318e7cc72204a26d9f788e744498ba58bc0f2f374260aca9bd2ad697ceddf36bbd
+DIST xfce4-panel-4.17.3.tar.bz2 1428565 BLAKE2B a5a1f44eecd53f3ad5419dfe33aa444318d4808e14b68dcc9c986efc75eb7e9e9da613855ca3b1ec6bd02676ad0707b607911c8fccde5f9b843b8e3c8d991601 SHA512 43b9f258fa0938007e4583130b7498ae01b44ab6631f453cef05f7c2970d71e9adb34cd13ce35eb095d6b3fc5097c604c07881a1e78a9173ec6e6733cfd58cbd
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.17.3.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.17.3.ebuild
new file mode 100644
index 000000000000..1779f20fe84f
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.17.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala xdg-utils
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+dbusmenu introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.66
+ >=x11-libs/cairo-1
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libX11
+ x11-libs/libwnck:3
+ >=xfce-base/exo-0.11.2:=
+ >=xfce-base/garcon-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.1:=
+ >=xfce-base/libxfce4util-4.17.2:=[introspection?,vala?]
+ >=xfce-base/xfconf-4.13:=
+ dbusmenu? ( >=dev-libs/libdbusmenu-16.04.0[gtk3] )
+ introspection? ( dev-libs/gobject-introspection:= )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ vala? ( $(vala_depend) )
+ dev-lang/perl
+ dev-util/gdbus-codegen
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable dbusmenu dbusmenu-gtk3)
+ $(use_enable vala)
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}