summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-15 15:43:38 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-15 16:04:01 +0100
commite31c206ae1f7e0184fb7a8736e4ad8baefd6fed2 (patch)
treea044a2fb8355e1d998a405927ac14ae188f24bb0 /xfce-base/xfdesktop/xfdesktop-4.18.0.ebuild
parentxfce-base/xfdesktop: Remove old (diff)
downloadgentoo-e31c206ae1f7e0184fb7a8736e4ad8baefd6fed2.tar.gz
gentoo-e31c206ae1f7e0184fb7a8736e4ad8baefd6fed2.tar.bz2
gentoo-e31c206ae1f7e0184fb7a8736e4ad8baefd6fed2.zip
xfce-base/xfdesktop: Bump to 4.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfdesktop/xfdesktop-4.18.0.ebuild')
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.18.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/xfdesktop-4.18.0.ebuild b/xfce-base/xfdesktop/xfdesktop-4.18.0.ebuild
new file mode 100644
index 000000000000..e8edad1d0122
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.18.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfdesktop/start
+ https://gitlab.xfce.org/xfce/xfdesktop/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+DEPEND="
+ >=x11-libs/cairo-1.16
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=x11-libs/libwnck-3.14:3
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-4.17.10:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}