summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 09:00:01 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 09:00:01 +0100
commit7bfdcd4bac79e67256f5eeecd3616b61e2fa206a (patch)
treeb73f597148e86436c0b521ace92c48f6d18a8a2f /xfce-base/xfdesktop
parentxfce-extra/tumbler: Bump to 4.16.0 (diff)
downloadgentoo-7bfdcd4bac79e67256f5eeecd3616b61e2fa206a.tar.gz
gentoo-7bfdcd4bac79e67256f5eeecd3616b61e2fa206a.tar.bz2
gentoo-7bfdcd4bac79e67256f5eeecd3616b61e2fa206a.zip
xfce-base/xfdesktop: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.16.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 38c075dc883d..da7de24c0719 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,2 +1,3 @@
DIST xfdesktop-4.14.3.tar.bz2 1549953 BLAKE2B 338d80d8acf50235c0763e9de9dfe6fd933769b7f46ffa322eabca252761b13c5024c780aaec8e87e1d1ff08ce21e63e6ae871ad030daa0cedbd7734dbd94613 SHA512 30e5ce74468f8f56b78144bea9dca620af19aef031c86968eb40b0a804a7a767f3cf817994bbdc6ed096b4558fab3e59062fb832d79f7dc3455df9b5540577f8
DIST xfdesktop-4.15.1.tar.bz2 1528853 BLAKE2B 71e16095441e9310efc9d8885538cc5c93649b9a1c9bfa499710b6564a52e352198a47bfc66c36f9b0e3eb3b39c7df7655f5fdaf7d9c50050225930eee727879 SHA512 62f64e120b373526b3c370d553575cfeb5719364bc64f069f4d859961f82fdb90d1332b243b90a63f1dd2e7d9609ad64ef81de17487cfea0c7c6d62f27db06cd
+DIST xfdesktop-4.16.0.tar.bz2 2041114 BLAKE2B 153a11b27b3ac92ded0c97257f19b4bc9018f384d201b41d82dd07df26ced7b5ded19ac98f80fb14e018d2df848f10b93cf629f05a66cc3b29e08313805fcf38 SHA512 e62e5fb12997c3138fa36aed06388b921f5223ec09afbd22b622ef39bc421773acbf73606ffc3b38b5a01845678847cda43d193c8457608715cf750acd466129
diff --git a/xfce-base/xfdesktop/xfdesktop-4.16.0.ebuild b/xfce-base/xfdesktop/xfdesktop-4.16.0.ebuild
new file mode 100644
index 000000000000..687fde786cb8
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.16.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+RDEPEND=">=x11-libs/cairo-1.12
+ >=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.14:3
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-1.7:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}