summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-14 04:12:57 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-14 04:53:12 +0100
commit02a2d0189466e0c2a85d1c11d142bdacc73ac652 (patch)
treeb030e0318c321f320033ec5ace1f60e783e36310 /xfce-base
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-02a2d0189466e0c2a85d1c11d142bdacc73ac652.tar.gz
gentoo-02a2d0189466e0c2a85d1c11d142bdacc73ac652.tar.bz2
gentoo-02a2d0189466e0c2a85d1c11d142bdacc73ac652.zip
xfce-base/libxfce4ui: Bump to 4.15.1
Closes: https://bugs.gentoo.org/702174 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.15.1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 11b92ed3de53..53ac974e0a75 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.14.1.tar.bz2 756175 BLAKE2B d487cc0a04b6053ead6670eeb83cafe1c4098818d5ad6a94a81176720d78cfd65160156961cbb526baa1640ae66a5c6958f707b7078c412d81fcd24cc8cf4013 SHA512 f42f41da3a683a0c56c3b1e7ba420c4f50909d2613e681d053b09b50bc0eb7f750f44c892e94b0ee8b9207983a87c0cadbda1ad93d0df74ae351dc8812025407
DIST libxfce4ui-4.15.0.tar.bz2 711299 BLAKE2B 60e13f3ed415fb138b256f19ec81b13bafb3f1223a996b18ef93b847346b593246012e8bded9c88dc5a905f355eb838b2295c0c91c8eb6d0d966efe748a0e15f SHA512 0a430d79dcc0088b061b020c78235775da5829b9c862e7201db4abca0d1753198c21f43ec0649e6c434ac9b382ff920a250895cb7ca38691a60f86e2e07fe6d0
+DIST libxfce4ui-4.15.1.tar.bz2 720332 BLAKE2B 198a162c2dd47d83102da8aee0c7943c869d708e36f2e0806988f63fb1f88c84c0b9ee3b5a6b14279a5359fa2afc1dfe7f8faedaff281635e0a2299a3a06618c SHA512 1b46109b79b849b38de7e8ebf0958ab5edace48cfc0a8b58c07d29d5f9b73998e078f6aa27650c0b30898cad5c251cdc45303e13982c1bb72101f9bc13d72f10
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.15.1.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.15.1.ebuild
new file mode 100644
index 000000000000..d7598a86b7a2
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.15.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection libgtop startup-notification vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.12:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libgtop? ( gnome-base/libgtop )
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable libgtop glibtop)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}