summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-27 08:04:30 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-27 08:04:30 +0200
commit0a655f20aed00fbbd799c4b259623a58fa2311bb (patch)
tree22610ca927a7052789017ddaf9caeeca55335d49 /xfce-base
parentnet-analyzer/fprobe: ppc stable wrt bug #798738 (diff)
downloadgentoo-0a655f20aed00fbbd799c4b259623a58fa2311bb.tar.gz
gentoo-0a655f20aed00fbbd799c4b259623a58fa2311bb.tar.bz2
gentoo-0a655f20aed00fbbd799c4b259623a58fa2311bb.zip
xfce-base/libxfce4util: Bump to 4.17.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index f984ea0d949d..2dc9dc8acb85 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1 +1,2 @@
DIST libxfce4util-4.16.0.tar.bz2 508328 BLAKE2B 99578b898389bd90841a7f903f5473b2ff357cf81256efe1019425b48da32401ce238deffefd299987477f4cdfb77e86e415b55049863c30bf16e0e641e08c72 SHA512 dce6992c3da73367461d7464794a9b2a5503666113682e07a86e18b1c5383de2b087809448d5729097571f4fda6b4af5f4f4600848514ab2ab4b3f367ca26f5c
+DIST libxfce4util-4.17.0.tar.bz2 531849 BLAKE2B 5c5de18703ade8bfa6a6be823144839afc309422131c06679a54b405c8d6aced4f1ccd0b9d0158931b6eed90aa48ab29789d1173c98541f92d3813c197283762 SHA512 4cdca029fb5e8b1cb5b34ca54aa1003918626824ee162adf43cede4c717b5e9705a5c0ff73f1a6348db320c4f3dddf4c9b8c760fba55f00d42bdb8fe7a9d90fa
diff --git a/xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild b/xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild
new file mode 100644
index 000000000000..f17b8a526eb7
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.17.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.50
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}