summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-17 15:12:04 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-17 15:49:52 +0200
commit1b1a2d75df86fe3d7415bd73ce0b0a5506e03da8 (patch)
tree40464c84a0ad71cb25ac679ddb675d7fefe8dfc6 /xfce-base
parentxfce-base/xfconf: Bump to 4.18.1 (diff)
downloadgentoo-1b1a2d75df86fe3d7415bd73ce0b0a5506e03da8.tar.gz
gentoo-1b1a2d75df86fe3d7415bd73ce0b0a5506e03da8.tar.bz2
gentoo-1b1a2d75df86fe3d7415bd73ce0b0a5506e03da8.zip
xfce-base/tumbler: Bump to 4.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/tumbler/Manifest1
-rw-r--r--xfce-base/tumbler/tumbler-4.18.1.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/xfce-base/tumbler/Manifest b/xfce-base/tumbler/Manifest
index b3af75a809a5..269f25278449 100644
--- a/xfce-base/tumbler/Manifest
+++ b/xfce-base/tumbler/Manifest
@@ -1 +1,2 @@
DIST tumbler-4.18.0.tar.bz2 609664 BLAKE2B f18c8786b0dee452526b1fda34c6a1d442655d8c252cb68cb1593c121fb2daaee520cc7958936e6ba0492b2eddacb7722fde937092bdde91ca34d4ca3ab42667 SHA512 60f0621ab1a7a00909ea04181c7dfb733dfbb33219991b2f81f991c289428e026993639ee1ffa5b46dd6f35866e0a3ad76fadbd11eec5fa926fba0da2278b99f
+DIST tumbler-4.18.1.tar.bz2 613283 BLAKE2B 8473e263dbecc8df40184d6cfce49b300799e576884372fbd285858da834e6b6e76f5fda23e5965660a596210ad1e86a936e5e6f1a1d7aafbc8b8467769cf35d SHA512 5b781e4a53b5a1f210ee9d373d4a1e26864d6c6afe64e056267c7ffb5e4ac77f56e0fe2c4e5cefccb1910041af0ee2828a2f62b4ab86a689eca9a5b30ab6048d
diff --git a/xfce-base/tumbler/tumbler-4.18.1.ebuild b/xfce-base/tumbler/tumbler-4.18.1.ebuild
new file mode 100644
index 000000000000..e1def53eb201
--- /dev/null
+++ b/xfce-base/tumbler/tumbler-4.18.1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A thumbnail service for Thunar"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/tumbler/start
+ https://gitlab.xfce.org/xfce/tumbler/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl epub ffmpeg gstreamer jpeg odf pdf raw"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ media-libs/freetype:2=
+ media-libs/libpng:0=
+ >=sys-apps/dbus-1.6
+ >=xfce-base/libxfce4util-4.17.1:=
+ >=x11-libs/gdk-pixbuf-2.40.0
+ curl? ( >=net-misc/curl-7.32.0:= )
+ epub? ( app-text/libgepub )
+ ffmpeg? ( >=media-video/ffmpegthumbnailer-2.0.8:= )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ jpeg? ( media-libs/libjpeg-turbo:0= )
+ odf? ( >=gnome-extra/libgsf-1.14.20:= )
+ pdf? ( >=app-text/poppler-0.12.4[cairo] )
+ raw? ( >=media-libs/libopenraw-0.0.8:=[gtk] )
+"
+RDEPEND="
+ ${DEPEND}
+ gstreamer? ( media-plugins/gst-plugins-meta:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable curl cover-thumbnailer)
+ $(use_enable epub gepub-thumbnailer)
+ $(use_enable jpeg jpeg-thumbnailer)
+ $(use_enable ffmpeg ffmpeg-thumbnailer)
+ $(use_enable gstreamer gstreamer-thumbnailer)
+ $(use_enable odf odf-thumbnailer)
+ $(use_enable pdf poppler-thumbnailer)
+ $(use_enable raw raw-thumbnailer)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}