summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-13 20:58:33 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-13 20:58:33 +0100
commit3e6493bf3ac445f66cb9b8f665b165c5170536b5 (patch)
tree999dce3b8a8f4f229eb97d597129eec209ff68bc /xfce-base
parentnet-misc/youtube-dl: Bump to 2020.12.14 (diff)
downloadgentoo-3e6493bf3ac445f66cb9b8f665b165c5170536b5.tar.gz
gentoo-3e6493bf3ac445f66cb9b8f665b165c5170536b5.tar.bz2
gentoo-3e6493bf3ac445f66cb9b8f665b165c5170536b5.zip
xfce-base/libxfce4util: Bump to 4.15.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.15.6.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index a9ef3d7ca966..c5c104d36fdf 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -2,3 +2,4 @@ DIST libxfce4util-4.14.0.tar.bz2 516358 BLAKE2B d8e3d1e3247e23908456aa296415240c
DIST libxfce4util-4.15.3.tar.bz2 521420 BLAKE2B a6d0d5e56c32c3e6950af26da12ad54d94e2cd9d7e172167e43a5c4d262709b2972e1a29e9fb348ac12d8e72568330449fc279a701dd9fe9e98a788cffd33b23 SHA512 1754cc5f4582151a1eb381606d32b0744193982177165e2b227655790849f9799a53739f1c36ed31b1a77cab28526d22e3cb6dab401e4a3b8ff29f1d2ea885ba
DIST libxfce4util-4.15.4.tar.bz2 527128 BLAKE2B 96825cc800becf4ec227d754ee53d244ad2f615c4a918d5bd88f42157bcd97e6e50d8162a35506ed531ed68da07a485e68758c702a4727eec76cacbf9ef4f817 SHA512 f18c6996c68925b3f8bb457225e6540881e62f8c524245d900f5d443fb1b5ff603afb536f0247e0d8b772df421225daea8184c1ac3c9b1228e53be12563ed468
DIST libxfce4util-4.15.5.tar.bz2 523132 BLAKE2B d6afe65a596febd32fa777ab96366591b30970c323067459766843a5e9cb2ebca2cf2bb85953c5593bca517bf8b8ab06f3260b740c8c863a23311b66c7c80168 SHA512 e9e936d3723ad7589b97f6ae2e7b4eb1454be0a84784f8f862780f87582bdab06c6087d67e3a5c695a3cb8b0be272d433792e2023789eae29e6614274d3bfb70
+DIST libxfce4util-4.15.6.tar.bz2 523102 BLAKE2B 2af9b631dcff75dfb83997a6daa1729aee46929da4c028dd5013b6b801d87758c06b2a9e738ff7734343024c6b2f416828ca1ce0f3cef6b7df252daf3c5d987e SHA512 6241ce0457f99274bdb864fe46c3e4d72e84dcd01bca515505dcab22ceb51a46bae75d586587a4129f45fdb7cefd627e17f4399ef6d6692c2b343a8caed3feef
diff --git a/xfce-base/libxfce4util/libxfce4util-4.15.6.ebuild b/xfce-base/libxfce4util/libxfce4util-4.15.6.ebuild
new file mode 100644
index 000000000000..f7d468347592
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.15.6.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.50
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}