summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-21 23:13:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-21 23:15:00 +0100
commit51e18175145d0c30a5f54ce4ef4711ad7eed5757 (patch)
tree442b2386e93ffc759fedb60a70845f0c11450684 /xfce-base
parentxfce-base/libxfce4util: Bump to 4.17.2 (diff)
downloadgentoo-51e18175145d0c30a5f54ce4ef4711ad7eed5757.tar.gz
gentoo-51e18175145d0c30a5f54ce4ef4711ad7eed5757.tar.bz2
gentoo-51e18175145d0c30a5f54ce4ef4711ad7eed5757.zip
xfce-base/libxfce4ui: Bump to 4.17.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.17.4.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 2283e86fc885..a221eec2585c 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.16.1.tar.bz2 785811 BLAKE2B d1267b328b7e2d07bfe85ce320da6a60d5a7d739c5ded9b213b83b0cde2061d3badc937e71c4353291ed435fb9d1294cadcc99402cdae69f4bcecf412dd525f2 SHA512 c183bbc75539c777fe704d0a1c4e533fdd2efb6cbc980cfedc2eaa80d0e6223db038498774ffcdc720d7f991dd8d9634183a757a4c4d1728cc9956a33cb187d0
DIST libxfce4ui-4.17.3.tar.bz2 886464 BLAKE2B f6e6b03b5612b45250f795c12cc657c356474dce4d9ecfbe265ff53339f592ad99bc0f2f819bd6899dce5fe337c2655eaa4176ef73c9127a8297976e39bcbedc SHA512 3c41cc922b7a97a81353eafa40f8828289e672514c2d0fabff2fe16f15ff6017c4cca6126f7e00ed321e0d286afc2c5726cc4f40f97ef7146533badfbfdea35c
+DIST libxfce4ui-4.17.4.tar.bz2 853808 BLAKE2B 1b3c4b9266a4c57ba3cfa518542bd860d2add23ed134e63b8a71111bac11672ca776fbededaaf0d374a6cac1ed3559bb4258caeec3ce1b3d758afb89bb2deac6 SHA512 eba085b7a0cd0e01600a7ab9659cb5f19d559a134c00f2036109b633dbfc79a0fd0f2db2b350e53f8266f4ff2b1961e193d7e6930488a4a7885d8606804bf5e9
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.17.4.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.17.4.ebuild
new file mode 100644
index 000000000000..757934a0db33
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.17.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade +introspection startup-notification system-info vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3[introspection?,X]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ startup-notification? ( x11-libs/startup-notification )
+ system-info? (
+ dev-libs/libgudev
+ gnome-base/libgtop
+ >=media-libs/libepoxy-1.2
+ )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable system-info glibtop)
+ $(use_enable system-info epoxy)
+ $(use_enable system-info gudev)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}