summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-05 11:04:09 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-05 11:16:52 +0100
commit65edb74a9d0af0367f1e764c4c85168f4fcacc0e (patch)
tree90d088c23c225c263c62c5954657e4569ab23b14 /xfce-base
parentnet-libs/libhtp: add self as maintainer (diff)
downloadgentoo-65edb74a9d0af0367f1e764c4c85168f4fcacc0e.tar.gz
gentoo-65edb74a9d0af0367f1e764c4c85168f4fcacc0e.tar.bz2
gentoo-65edb74a9d0af0367f1e764c4c85168f4fcacc0e.zip
xfce-base/libxfce4ui: Bump to 4.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.15.0.ebuild67
-rw-r--r--xfce-base/libxfce4ui/metadata.xml1
3 files changed, 69 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 4e53a3033ffa..09c728f5424a 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4ui-4.13.4.tar.bz2 684065 BLAKE2B 1da875832683b5e06b8e91b4078be8122ae85a91560d7b1768cb8c880fcf5e1d7cd07d24927ae3325ba9c500c6c2cd30e717e517775492b9948add0711f5aa40 SHA512 c82d6ff7ea0da4fc0f664bab92f1e9531162996a26bb092e6ba651cfc4551732cbcd8023908d428b47906c17c331c14bf4804256566ca564befa218dc1194206
DIST libxfce4ui-4.14.1.tar.bz2 756175 BLAKE2B d487cc0a04b6053ead6670eeb83cafe1c4098818d5ad6a94a81176720d78cfd65160156961cbb526baa1640ae66a5c6958f707b7078c412d81fcd24cc8cf4013 SHA512 f42f41da3a683a0c56c3b1e7ba420c4f50909d2613e681d053b09b50bc0eb7f750f44c892e94b0ee8b9207983a87c0cadbda1ad93d0df74ae351dc8812025407
+DIST libxfce4ui-4.15.0.tar.bz2 711299 BLAKE2B 60e13f3ed415fb138b256f19ec81b13bafb3f1223a996b18ef93b847346b593246012e8bded9c88dc5a905f355eb838b2295c0c91c8eb6d0d966efe748a0e15f SHA512 0a430d79dcc0088b061b020c78235775da5829b9c862e7201db4abca0d1753198c21f43ec0649e6c434ac9b382ff920a250895cb7ca38691a60f86e2e07fe6d0
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.15.0.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.15.0.ebuild
new file mode 100644
index 000000000000..c412d638a219
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.15.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection libgtop startup-notification vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.12:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10 )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libgtop? ( gnome-base/libgtop )
+ startup-notification? ( x11-libs/startup-notification )"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable libgtop glibtop)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/xfce-base/libxfce4ui/metadata.xml b/xfce-base/libxfce4ui/metadata.xml
index c9c136a2dab2..b16ea0c2efba 100644
--- a/xfce-base/libxfce4ui/metadata.xml
+++ b/xfce-base/libxfce4ui/metadata.xml
@@ -8,5 +8,6 @@
<use>
<flag name="glade">Build support for Glade 3's GtkBuilder implementation</flag>
<flag name="gtk2">Build deprecated GTK+2 libxfce4ui-1 library.</flag>
+ <flag name="libgtop">Enable system information via <pkg>gnome-base/libgtop</pkg>.</flag>
</use>
</pkgmetadata>