summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 00:21:47 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 00:35:41 +0100
commit8fbd04a77986374e87ad3d90fe6136b28b5bc9ab (patch)
tree785e3f180b3923c75f2a38846dcd30247edb02fb /xfce-base
parentdev-python/keyring: Bump to 21.7.0 (diff)
downloadgentoo-8fbd04a77986374e87ad3d90fe6136b28b5bc9ab.tar.gz
gentoo-8fbd04a77986374e87ad3d90fe6136b28b5bc9ab.tar.bz2
gentoo-8fbd04a77986374e87ad3d90fe6136b28b5bc9ab.zip
xfce-base/libxfce4util: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.16.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 5a904ae7758b..29078091f0d4 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4util-4.14.0.tar.bz2 516358 BLAKE2B d8e3d1e3247e23908456aa296415240c1a9146001a02cb859541922ee541e30955279fd68f2d9938e43f992a5115b21836363fa8d8234de87fca0bbaac830bf0 SHA512 6ac95aea03052d9e2f886cbe76afe9bbb43511bf3fe1766097e10cd8762541ed17060a727df3ef93e226aae448c15d9dd3ad8acd55a9d5f2387cb360bdf72832
DIST libxfce4util-4.15.6.tar.bz2 523102 BLAKE2B 2af9b631dcff75dfb83997a6daa1729aee46929da4c028dd5013b6b801d87758c06b2a9e738ff7734343024c6b2f416828ca1ce0f3cef6b7df252daf3c5d987e SHA512 6241ce0457f99274bdb864fe46c3e4d72e84dcd01bca515505dcab22ceb51a46bae75d586587a4129f45fdb7cefd627e17f4399ef6d6692c2b343a8caed3feef
+DIST libxfce4util-4.16.0.tar.bz2 508328 BLAKE2B 99578b898389bd90841a7f903f5473b2ff357cf81256efe1019425b48da32401ce238deffefd299987477f4cdfb77e86e415b55049863c30bf16e0e641e08c72 SHA512 dce6992c3da73367461d7464794a9b2a5503666113682e07a86e18b1c5383de2b087809448d5729097571f4fda6b4af5f4f4600848514ab2ab4b3f367ca26f5c
diff --git a/xfce-base/libxfce4util/libxfce4util-4.16.0.ebuild b/xfce-base/libxfce4util/libxfce4util-4.16.0.ebuild
new file mode 100644
index 000000000000..de84c2ad3ba2
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.16.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.50
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}