summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 00:32:12 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 00:35:49 +0100
commit9985b032c0eba7233d276d174dd80358b22e22d3 (patch)
treed69608a872ac8fac1d49af7879ec0e92c537745f /xfce-base
parentxfce-extra/xfce4-power-manager: Bump to 4.16.0 (diff)
downloadgentoo-9985b032c0eba7233d276d174dd80358b22e22d3.tar.gz
gentoo-9985b032c0eba7233d276d174dd80358b22e22d3.tar.bz2
gentoo-9985b032c0eba7233d276d174dd80358b22e22d3.zip
xfce-base/thunar: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.16.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 0b597ff9f6f0..97d9acb7b420 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,3 @@
DIST thunar-1.8.16.tar.bz2 2479718 BLAKE2B 2de72f0b9977a9815c0a7f0376ceb01ddd5a68dda6c33e7d99f34378f00086e6652fa2cfcecd12129811ed6e78d45c7a1b321563ad98c5257bb6d3c58689c60d SHA512 1d096c7328b6131f097663d8f769a1e7a2a15cb24ca5116e28de38162cf1c5c544b8ed856b0d3df758947154b9e76ca720d3c614e7dca4edb71e8a219438e7a7
DIST thunar-4.15.3.tar.bz2 2445923 BLAKE2B 7c1fcbb77eba1a2198bbfac88d43d9a332941aca9dec46d239933288d6e97d4029208bcbe6574577d71aad11292c2ca8015374502b724fa3e3844f0fa664152b SHA512 a86a2e984ccbec82f50b479efc61334615b0ac116d8b3a479c61470d34fe47bac0d3e327cf4e10a1bf3ad50910abb26767bbd7ffed0cf4263e3435a21e1ab6dd
+DIST thunar-4.16.0.tar.bz2 2454813 BLAKE2B 528abf3f3227992dbed23e453205a55dcdda8bf03d242f6668e45e2d22921dfe5f5dd5550a7cdf53fd5c39c21ecf9567bc02e2d178ae7a1d35ad0c4f6932e4a7 SHA512 0f288018ead108c6a170a9b98d45d6c005301eb51526b357ab81411724451f0e6a1154ae44dd7681ee5bc9a8807df1497ed26d1af0ac002d68c69fede808cc51
diff --git a/xfce-base/thunar/thunar-4.16.0.ebuild b/xfce-base/thunar/thunar-4.16.0.ebuild
new file mode 100644
index 000000000000..647aad08c705
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.16.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+DEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.50
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-0.12:=
+ >=xfce-base/libxfce4ui-4.15.3:=
+ >=xfce-base/libxfce4util-4.15.2:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )"
+RDEPEND="${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}