summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-01 22:11:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-01 22:11:50 +0100
commitab6359ace5a1c1a68fd3692013ccc14d32f09af2 (patch)
tree8bc66d5d5b09391f9eaa6f718be3210e0e157019 /xfce-base
parentnet-irc/konversation: Drop 1.7.7 (r0) (diff)
downloadgentoo-ab6359ace5a1c1a68fd3692013ccc14d32f09af2.tar.gz
gentoo-ab6359ace5a1c1a68fd3692013ccc14d32f09af2.tar.bz2
gentoo-ab6359ace5a1c1a68fd3692013ccc14d32f09af2.zip
xfce-base/exo: Bump to 4.15.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.15.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 385938017501..28e15790effd 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-0.12.11.tar.bz2 1333227 BLAKE2B 4e95809c58b6db26ecdf524663c06df9cd70007726091e381a1f0dd58be52efee85ad9721c421c0df6438073bb9de97d56cd039f520e2f7c0f5722a1839ba167 SHA512 ecbf20feddf86178d34a5c70212f0c2310ab1d6ce25291846d6d1d3045270ae3e68102065d7b3d8840137406f826f9bc37fed92a16c1268c3d14f2833a97d533
DIST exo-4.15.2.tar.bz2 1010181 BLAKE2B 02b6cee68de61b1580e1676f7206f8f48f8c7c1a17050bf44e0ff922675ebd1a0eeceae2adc9f004e7e73a7e878af21867d7ca61c2fde9f10b2f80e917d1a318 SHA512 9b5838d2a69876164e5a89bd474428ace39bfb8f651bbe6c0873b52359893e40e156c862fb8a9f9ac3138ff2fa153e10085326e41045a41771e8961d3c0823f3
+DIST exo-4.15.3.tar.bz2 994455 BLAKE2B 9c62b31a2f5cba4853263ea0b155fc3e5439170c7cc3011c03022a5419a9a0910c4b47431cf916f6e6ad4a5d2580e488ba8a18e4bbaa4d97d35a61711fd4a93a SHA512 3da0a0aadd15e140e43eece56bb92872e05f90b0da88368a84f3d3bc8d53c19d12549693fe00518937a691a3af559d1dba3170fa2490a64dbc26fa2f7faf13ea
diff --git a/xfce-base/exo/exo-4.15.3.ebuild b/xfce-base/exo/exo-4.15.3.ebuild
new file mode 100644
index 000000000000..aa7befedb775
--- /dev/null
+++ b/xfce-base/exo/exo-4.15.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-libs/glib-2.42
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}