summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-28 17:45:06 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-28 17:45:06 +0200
commitc58af218ec607cc813d1cab2dbe795ccab4c2fc2 (patch)
tree025419f063c7c41dee892bfcbc04301d40459631 /xfce-base
parentxfce-base/xfdesktop: Drop old (diff)
downloadgentoo-c58af218ec607cc813d1cab2dbe795ccab4c2fc2.tar.gz
gentoo-c58af218ec607cc813d1cab2dbe795ccab4c2fc2.tar.bz2
gentoo-c58af218ec607cc813d1cab2dbe795ccab4c2fc2.zip
xfce-base/xfdesktop: Bump to 4.13.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.13.6.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index 05357cba7ec2..8be7f581d050 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1,3 +1,4 @@
DIST xfdesktop-4.12.4.tar.bz2 1421623 BLAKE2B a18b891d639165d617f2701106dedb2f8577273ece5a4c93f6b5e1ef26f801304ea2014f21bd2821eb9bac9b19e02dd75cd4054a116eefd544f4d8e5d6968879 SHA512 29f170b96836298dc83e3c49650ab7e88a93c1a2fa1599d1d98f3b6c80c9c059748b76a821077eea39b5b4619998bb300ff17f06e88483a59bd5ae2b76d0605e
DIST xfdesktop-4.12.5.tar.bz2 1442736 BLAKE2B 2f4d60fff062779123ab70b8e4d56cd67ea783b7c2aed00a39773b66e20b60fc4189e899ad3c17c70afcd1674bae72a4f574c952a11ba1f40860f35eb8e6869a SHA512 0217a220e7d6d9f95277d5a2dd047c133b65b0ccf21510cd949241b594f244a726147d0d0256e3f32d6989710e6e074710c1a63b46a88587a5ef7238cbb8a92d
DIST xfdesktop-4.13.5.tar.bz2 1487498 BLAKE2B 3884cba5da1798470462ac3b49537ff3dbe108624587e49d5b26755087b13c8858414c7498da5fc4f6471fe71d68ed689cda490f75bd9acede5077639ca89b6d SHA512 5191a28d29f9ba7960ada37055867fabccd2c7b047671331aadbb8d7a03a73dd5b7dd5f6043dd2f0226fa734262b52d22f0c6b77d56007a973aa01da9340f448
+DIST xfdesktop-4.13.6.tar.bz2 1487655 BLAKE2B 288d37e316a13dc7de4ab5964344ac4dbd181719f2d4212e87da797095fd58893a7ff599c7614197ac268c0eae09dfc52b5108039bff45be829c64a71f0913c6 SHA512 260d228439a5ba12b6f5e7ed7f165c5668279a27399f51447ca8a8c493293bbc4fda817d797c0122d1a3e367a4c30f8cd607793225ce22007003705b2fc7a368
diff --git a/xfce-base/xfdesktop/xfdesktop-4.13.6.ebuild b/xfce-base/xfdesktop/xfdesktop-4.13.6.ebuild
new file mode 100644
index 000000000000..70cc7ded6321
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.13.6.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+RDEPEND=">=x11-libs/cairo-1.12:=
+ >=dev-libs/glib-2.42:=
+ >=x11-libs/gtk+-3.22:3=
+ >=x11-libs/libwnck-3.14:3=
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? (
+ >=dev-libs/glib-2.38:=
+ >=xfce-base/thunar-1.7:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}