summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-28 17:24:54 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-28 17:43:19 +0200
commite3d51214d95b090a816552af61d726a4a2964759 (patch)
tree16cb8078f36e809eeea0dbae75bbbb8df5933c72 /xfce-base
parentxfce-extra/tumbler: Drop old (diff)
downloadgentoo-e3d51214d95b090a816552af61d726a4a2964759.tar.gz
gentoo-e3d51214d95b090a816552af61d726a4a2964759.tar.bz2
gentoo-e3d51214d95b090a816552af61d726a4a2964759.zip
xfce-base/libxfce4util: Bump to 4.13.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.13.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 05c907d8dfa4..034afe17a5c8 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,3 +1,4 @@
DIST libxfce4util-4.13.2.tar.bz2 509280 BLAKE2B 40f1fb95abff4857e976dd5f3ae8c8ad5e66e2c1c49723735e85124db71d30f204525cd74baf22e31bf405718f378b0c9ac37ec4189e1f4b9941d0eb6fc141ce SHA512 3bbb718f3a6d2213c86695b3f99d1e67c859ce635e5d066b18745d2ee57c0b2eea468b61079d8e2514c2d8f5fa847539d236ec0ed3fd17fecd9d1b36dc3595c4
DIST libxfce4util-4.13.3.tar.bz2 511277 BLAKE2B 0815808166bc488cfa3636a18c9486fd1b3a81376766a77eef80ee24274bb290b9bece5e7786f7e412154f201bef251ce90d350c9e69db79bb893fd9081d2dac SHA512 e06bf58d46c5c3c6964a17ca8d998bd8e78bb61577ddcd855680878a890912a167212a2b4e3b347f41f84d2983e71fd1d76716db9c4a88a1d4f45a0f5aaf5e51
DIST libxfce4util-4.13.4.tar.bz2 501426 BLAKE2B 623978a933902cc939e4cd537e9efe1e8d6b5028103f66682d76636c17e16bfd5fc56631622a00a1e4cbba6ba45495ec8d8dd05335d1a073a9c811c13732ef88 SHA512 7d474839acbc2b4f75cb39e39053214bac43b5da9f7605aec8e78bfc1ab1a07864429a47f18faae9be8dfecbb7f5a055bd2eb20c0b9d1b4912755b81cac1ada2
+DIST libxfce4util-4.13.5.tar.bz2 501748 BLAKE2B 2faee4f20f8a28c207fb9c20c15db92d336c5e86d6d9c64596a6670f043ad4a551e6f18779f1b52419a41d1bfe1f3e80b4c073e630dabefc5de3cd3c80b3359b SHA512 a7b5f540adbbb81d6382072f3fac4d919bb3be691f647cd70a5b8ef026e64d68ff5a7e340bb75df999145702b7dfc1a6e493e6f635e3d64ab78bf8831082e565
diff --git a/xfce-base/libxfce4util/libxfce4util-4.13.5.ebuild b/xfce-base/libxfce4util/libxfce4util-4.13.5.ebuild
new file mode 100644
index 000000000000..eebcd790a572
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.13.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:=
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}