summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/thunar-archive-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/thunar-archive-plugin')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch68
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch15
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch15
-rw-r--r--xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch22
-rw-r--r--xfce-extra/thunar-archive-plugin/metadata.xml8
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild31
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild35
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1.ebuild28
9 files changed, 223 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
new file mode 100644
index 000000000000..ca50c6791581
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -0,0 +1 @@
+DIST thunar-archive-plugin-0.3.1.tar.bz2 329005 SHA256 9ad559b0c11308f6897ad56604e5a06dc8f369f649eb20120b2d3018ef5da54c SHA512 51157c2680b3fcc6b541d35fc2943a350a0354d7d5bbb5fbe8a9dcbbeaf4bf4f5fe62521b8e9a73254f70bbefc440357deade8181313da96270c280eb0464e68 WHIRLPOOL 151a505968b871eae82bff1799464e4c6042e99668ec4752ecfa7537ed6968886134941bfcc7741ad56ba8ebb429c021046a968db92b1bba89bf1a1d2bb4a0d1
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch
new file mode 100644
index 000000000000..32d1b31e0c72
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-engrampa-support.patch
@@ -0,0 +1,68 @@
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 4da529c..ec49cba 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -3,7 +3,8 @@
+ wrapperdir = $(libexecdir)/thunar-archive-plugin
+ wrapper_SCRIPTS = \
+ ark.tap \
+- file-roller.tap
++ file-roller.tap \
++ engrampa.tap
+
+ # Install symlink to 'gnome-file-roller.tap'
+ install-exec-hook:
+diff --git a/scripts/engrampa.tap b/scripts/engrampa.tap
+index e69de29..a9d9c10 100755
+--- a/scripts/engrampa.tap
++++ b/scripts/engrampa.tap
+@@ -0,0 +1,48 @@
++#!/bin/sh
++#
++# engrampa.tap - Wrapper script to create and extract archive files
++# in Thunar, via the thunar-archive-plugin, using the
++# engrampa archive manager.
++#
++# $Id$
++#
++# Copyright (c) 2006 Benedikt Meurer <benny@xfce.org>.
++#
++# This program is free software; you can redistribute it and/or modify it
++# under the terms of the GNU General Public License as published by the Free
++# Software Foundation; either version 2 of the License, or (at your option)
++# any later version.
++#
++# This program is distributed in the hope that it will be useful, but WITHOUT
++# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
++# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
++# more details.
++#
++# You should have received a copy of the GNU General Public License along with
++# this program; if not, write to the Free Software Foundation, Inc., 59 Temple
++# Place, Suite 330, Boston, MA 02111-1307 USA.
++#
++
++# determine the action and the folder, $@ then contains only the files
++action=$1; shift;
++folder=$1; shift;
++
++# check the action
++case $action in
++create)
++ exec engrampa "--default-dir=$folder" --add "$@"
++ ;;
++
++extract-here)
++ exec engrampa "--extract-to=$folder" --force "$@"
++ ;;
++
++extract-to)
++ exec engrampa --extract "$@"
++ ;;
++
++*)
++ echo "Unsupported action '$action'" >&2
++ exit 1
++esac
++
+
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch
new file mode 100644
index 000000000000..bbe5f566a4c5
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-add-support-symlinks.patch
@@ -0,0 +1,15 @@
+diff -ur thunar-archive-plugin-0.3.1.old/scripts/Makefile.am thunar-archive-plugin-0.3.1/scripts/Makefile.am
+--- thunar-archive-plugin-0.3.1.old/scripts/Makefile.am 2013-05-11 13:48:30.000000000 +0400
++++ thunar-archive-plugin-0.3.1/scripts/Makefile.am 2015-07-05 12:55:32.052090677 +0400
+@@ -9,8 +9,9 @@
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(wrapperdir)
+ -( cd $(DESTDIR)$(wrapperdir) ; \
+- test -f gnome-file-roller.tap \
+- || ln -sf file-roller.tap gnome-file-roller.tap )
++ ln -sf ark.tap kde4-ark.tap; \
++ ln -sf file-roller.tap gnome-file-roller.tap; \
++ ln -sf file-roller.tap org.gnome.FileRoller.tap; )
+
+ EXTRA_DIST = \
+ $(wrapper_SCRIPTS) \
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch
new file mode 100644
index 000000000000..094480212f12
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-file-roller.patch
@@ -0,0 +1,15 @@
+diff --git a/scripts/Makefile.am b/scripts/Makefile.am
+index 4da529c..2ba8dec 100644
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -9,8 +9,8 @@ wrapper_SCRIPTS = \
+ install-exec-hook:
+ $(mkinstalldirs) $(DESTDIR)$(wrapperdir)
+ -( cd $(DESTDIR)$(wrapperdir) ; \
+- test -f gnome-file-roller.tap \
+- || ln -sf file-roller.tap gnome-file-roller.tap )
++ ln -sf file-roller.tap gnome-file-roller.tap; \
++ ln -sf file-roller.tap org.gnome.FileRoller.tap; )
+
+ EXTRA_DIST = \
+ $(wrapper_SCRIPTS) \
diff --git a/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch
new file mode 100644
index 000000000000..e95fbbe0e407
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/files/0.3.1-fix-kde-ark.patch
@@ -0,0 +1,22 @@
+diff -ur thunar-archive-plugin-0.3.1.old/scripts/ark.tap thunar-archive-plugin-0.3.1/scripts/ark.tap
+--- thunar-archive-plugin-0.3.1.old/scripts/ark.tap 2013-05-11 13:48:30.000000000 +0400
++++ thunar-archive-plugin-0.3.1/scripts/ark.tap 2015-07-05 12:56:25.288680104 +0400
+@@ -30,15 +30,15 @@
+ # check the action
+ case $action in
+ create)
+- exec ark --add "$@"
++ exec ark --dialog --add "$@"
+ ;;
+
+ extract-here)
+- exec ark --extract-to "$folder" "$@"
++ exec ark --batch --destination "$folder" "$@"
+ ;;
+
+ extract-to)
+- exec ark --extract "$@"
++ exec ark --batch --dialog --autodestination "$@"
+ ;;
+
+ *)
diff --git a/xfce-extra/thunar-archive-plugin/metadata.xml b/xfce-extra/thunar-archive-plugin/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild
new file mode 100644
index 000000000000..51608e3d9692
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EAUTORECONF="yes"
+inherit xfconf
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/thunar-1.2:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/0.3.1-add-engrampa-support.patch "${FILESDIR}"/0.3.1-fix-file-roller.patch )
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild
new file mode 100644
index 000000000000..989dd0de3d65
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+EAUTORECONF="yes"
+inherit xfconf
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/thunar-1.2:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=(
+ "${FILESDIR}"/0.3.1-add-engrampa-support.patch
+ "${FILESDIR}"/0.3.1-fix-kde-ark.patch
+ "${FILESDIR}"/0.3.1-add-support-symlinks.patch
+ )
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1.ebuild
new file mode 100644
index 000000000000..c93d99c33ada
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.3.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-archive-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug"
+
+RDEPEND=">=xfce-base/libxfce4util-4.8
+ >=xfce-base/exo-0.6
+ >=xfce-base/thunar-1.2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}