summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-29 18:24:11 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-29 19:01:42 +0200
commit9925d7945f12c1c4c8b553039c841b2ad0b7b93c (patch)
treebc903b20e82f354af6adbb1247d3ee38554d297e /xfce-extra/thunar-vcs-plugin
parentxfce-extra/xfce4-notifyd: Bump to 0.3.0, first GTK+3/gdbus release (diff)
downloadgentoo-9925d7945f12c1c4c8b553039c841b2ad0b7b93c.tar.gz
gentoo-9925d7945f12c1c4c8b553039c841b2ad0b7b93c.tar.bz2
gentoo-9925d7945f12c1c4c8b553039c841b2ad0b7b93c.zip
xfce-extra/thunar-vcs-plugin: Bump to 0.1.5, with revamped svn support
Diffstat (limited to 'xfce-extra/thunar-vcs-plugin')
-rw-r--r--xfce-extra/thunar-vcs-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/thunar-vcs-plugin/Manifest b/xfce-extra/thunar-vcs-plugin/Manifest
index 3e9adb86d969..ac1da470e143 100644
--- a/xfce-extra/thunar-vcs-plugin/Manifest
+++ b/xfce-extra/thunar-vcs-plugin/Manifest
@@ -4,3 +4,4 @@ DIST thunar-vcs-plugin-0.1.4-ru.po.bz2 4323 SHA256 50f9f84162317e3bcc5243eb06882
DIST thunar-vcs-plugin-0.1.4-ug.po.bz2 4628 SHA256 ea50f843b721f7f1e31ec9abcba755a24c7834d2f3a64b309cf459e7a46f64e5 SHA512 563c6f235eb6e5a049846052e5bfad1ad6a40c598b013e83ad12d50c4a070bb3faec5362ec02c56bfac14d752918b65b7089bef729a1004245539c22d10255db WHIRLPOOL 2a4df5619f00580440308ceb0a6281ed67221ef3ca27ec4e88ec90dec6c5b73372f2c6cdd9c079a205677671844051069e40c7560a917dd3728a58f4da3acbe1
DIST thunar-vcs-plugin-0.1.4-uk.po.bz2 5469 SHA256 a43df313ce3a2968a83efa41a46193ef42b095913cbed27230d3ac092ca2b08a SHA512 e1b0b6ab444fb46d626c889b9b2509e21b00aa380c40da5b871a4e6c12fd34609bd0a74b2f7b5894601ad5fe4727fdb177ae7af0f0ef457f23021287d6dca8ff WHIRLPOOL afa9d171c22fdfa467958a1946ceb7d9b0726d7d3d80a8dacf1cd1241d45a5fa9e29f305d459a92656b9fb84c1c470ea36fdacf21e7922667b6790211a342c28
DIST thunar-vcs-plugin-0.1.4.tar.bz2 435835 SHA256 7dbbdb22113cec40f6dc46cf4fd113b47928af15ba64e9fc66305a01c4291d4c SHA512 037ca986ab9030146fc409d78d235a157b956b202449ef8e68de77dfce29ba2dd9a2dabc793215dd9ce455f97d8c5400ba51c8254b3c07b3e0d87572df672151 WHIRLPOOL ca5eafc6a3e0061c3b87afc93f1ede109b17919e8915565b004b3302d4e21493c1880b7645f90b2dcc288fde84c7249754f0652e8ebbe20139bab6d193b4ab1f
+DIST thunar-vcs-plugin-0.1.5.tar.bz2 478866 SHA256 7094f576865957397eefcdb1b05ba9be020a396c12949077507ea1573b1ef451 SHA512 0315613fe97d5cb2fa9589af49bdb5074f20c83b52d5f7d4a151091839679b4617e8e0b20df85914b7bcef2464173dc1bd2bc182312364c7d5a94171aba28983 WHIRLPOOL f5e90202bb852913414ff13de4bc2c0a35fd7cae572b7b64040cc0346bc83b16fc95b514f4f86cd73e6b6ca0b5faa19917af7bc76f9e27c0684665125131cd07
diff --git a/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild
new file mode 100644
index 000000000000..5ab8bba8f72f
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Adds Subversion and GIT actions to the context menu of thunar"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+SRC_URI="mirror://xfce/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +git +subversion"
+
+RDEPEND=">=dev-libs/glib-2.18:2=
+ >=x11-libs/gtk+-2.14:2=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/thunar-1.2:=
+ git? ( dev-vcs/git )
+ subversion? (
+ >=dev-libs/apr-0.9.7:=
+ >=dev-vcs/subversion-1.5:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable subversion)
+ $(use_enable git)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}