summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-13 13:31:30 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-13 14:10:47 +0200
commitb6333cbd5e99118d3d0cb872808a8872774ebc75 (patch)
tree7055f138a507b42202a339047a68f51cbb6791c0 /xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild
parentxfce-extra/xfce4-smartbookmark-plugin: Bump to 0.5.1 (diff)
downloadgentoo-b6333cbd5e99118d3d0cb872808a8872774ebc75.tar.gz
gentoo-b6333cbd5e99118d3d0cb872808a8872774ebc75.tar.bz2
gentoo-b6333cbd5e99118d3d0cb872808a8872774ebc75.zip
xfce-extra/xfce4-battery-plugin: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild')
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild
new file mode 100644
index 000000000000..4637bab90ff7
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ >=x11-libs/gtk+-3.16:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}