summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-24 18:45:24 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-24 18:49:38 +0200
commita57c85880af3b8d5696dbf5a0067e28d3d70873d (patch)
treef801b88b1f5468763d3d0b5b8f6e554bc52e7106 /xfce-extra/xfce4-diskperf-plugin
parentx11-misc/xdg-utils: amd64 stable wrt bug #666874 (diff)
downloadgentoo-a57c85880af3b8d5696dbf5a0067e28d3d70873d.tar.gz
gentoo-a57c85880af3b8d5696dbf5a0067e28d3d70873d.tar.bz2
gentoo-a57c85880af3b8d5696dbf5a0067e28d3d70873d.zip
xfce-extra/xfce4-diskperf-plugin: Apply proper sysmacros.h fix
Closes: https://bugs.gentoo.org/661994 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-diskperf-plugin')
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-sysmacros.patch24
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1-r1.ebuild40
2 files changed, 64 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-sysmacros.patch b/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-sysmacros.patch
new file mode 100644
index 000000000000..13a8df73bfe2
--- /dev/null
+++ b/xfce-extra/xfce4-diskperf-plugin/files/xfce4-diskperf-plugin-2.6.1-sysmacros.patch
@@ -0,0 +1,24 @@
+From dd62d6dae6ad77b586af69faf8fdee8d7c87051b Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Sat, 21 Oct 2017 00:14:32 +0200
+Subject: [PATCH] Add <sys/sysmacros.h> include required for glibc-2.25+
+
+---
+ panel-plugin/devperf.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/panel-plugin/devperf.c b/panel-plugin/devperf.c
+index 175fd44..9348c9e 100644
+--- a/panel-plugin/devperf.c
++++ b/panel-plugin/devperf.c
+@@ -35,6 +35,7 @@
+ #include <sys/time.h>
+ /* for major() and minor() */
+ #define _BSD_SOURCE
++#include <sys/sysmacros.h>
+ #include <sys/types.h>
+
+
+--
+2.15.0.rc1
+
diff --git a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1-r1.ebuild b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1-r1.ebuild
new file mode 100644
index 000000000000..6484f9ed6053
--- /dev/null
+++ b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.6.1-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="A panel plug-in for disk usage and performance statistics"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-diskperf-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ # https://bugzilla.xfce.org/show_bug.cgi?id=13940
+ # (simpler Linux-only version; portable version merged as 0787a89)
+ "${FILESDIR}"/xfce4-diskperf-plugin-2.6.1-sysmacros.patch
+)
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ gnome2_icon_cache_update
+}