summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-06 13:40:35 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-06 15:19:56 +0100
commitb44672be31e6fd317b20575de2c433fba28a0fc3 (patch)
tree104effd11e3c2f1f1153e09ada83509e5d4397b0 /xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r4.ebuild
parentxfce-extra/xfce4-mailwatch-plugin: libxfce4ui-4.15 has no gtk2 (diff)
downloadgentoo-b44672be31e6fd317b20575de2c433fba28a0fc3.tar.gz
gentoo-b44672be31e6fd317b20575de2c433fba28a0fc3.tar.bz2
gentoo-b44672be31e6fd317b20575de2c433fba28a0fc3.zip
xfce-extra/xfce4-notes-plugin: libxfce4ui-4.15 has no gtk2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r4.ebuild')
-rw-r--r--xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r4.ebuild b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r4.ebuild
new file mode 100644
index 000000000000..20c9cf8844ea
--- /dev/null
+++ b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.8.1-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 panel sticky notes plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-notes-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ >=x11-libs/gtk+-2.20:2
+ <xfce-base/libxfce4ui-4.15:=[gtk2(+)]
+ >=xfce-base/libxfce4util-4.10:=
+ <xfce-base/xfce4-panel-4.15:=[gtk2(+)]
+ >=xfce-base/xfconf-4.10:=
+ dev-libs/libunique:1="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ dev-util/intltool"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}