summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-16 10:54:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-16 10:55:26 +0100
commita6ddfee53043856813259a72ee33bd990fcefb18 (patch)
tree0b965ff6b10625dc792661448ee028097c6b1f08 /xfce-extra/xfce4-notifyd
parentxfce-extra/xfce4-taskmanager: Bump to 1.5.5 (diff)
downloadgentoo-a6ddfee53043856813259a72ee33bd990fcefb18.tar.gz
gentoo-a6ddfee53043856813259a72ee33bd990fcefb18.tar.bz2
gentoo-a6ddfee53043856813259a72ee33bd990fcefb18.zip
xfce-extra/xfce4-notifyd: Bump to 0.6.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-notifyd')
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest1
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.5.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index 7a65770fdf8a..432dbb1c9c55 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1 +1,2 @@
DIST xfce4-notifyd-0.6.4.tar.bz2 554776 BLAKE2B f594ee8a841e4074592a6377e79fde8dd89574620a433a9813f4ad106d712361e941b443de481cb9d140a47e7b1b4753116b4f949c39b6834926f0708877fb6e SHA512 644e2e49092892e386a9f82edc6ab3b2b59ba67617d9217fb43dd3cf74ae5cfc9b9bea6ed0fab4c4440eca68613aa996d9f8dc73deb1f60926217b7db18cc73b
+DIST xfce4-notifyd-0.6.5.tar.bz2 572193 BLAKE2B 498c8eecfd884aa04230fea2ecca3b663f0d6b59b549cc5a56d43ac20a17d4f15a1bd1e3ce8d1681de7307d569096bbbbe169ada447d41f7889daad5a35c8a8f SHA512 9953dd456520bd80e0d48da013703d7b976f953b9b41cd55f3ac236a74c55277d04f38a092e2a9024cd67cbcde3f3989daadf6b4f41e57c7e005c20f4acdf1ac
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.5.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.5.ebuild
new file mode 100644
index 000000000000..9dd4b8e18e5c
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.5.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/notifyd/start
+ https://gitlab.xfce.org/apps/xfce4-notifyd/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.56:2
+ >=x11-libs/gtk+-3.14:3
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.10:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}