summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-11-03 14:48:11 +0100
committerMichał Górny <mgorny@gentoo.org>2022-11-03 15:50:01 +0100
commite9ed63eb8a5df68ba376abe9dca396182bd52478 (patch)
treec8b8cfb4a66d0beacf5eea07903bc19b44931e0e /xfce-extra/xfce4-notifyd
parentdev-libs/libclc: Bump to 15.0.4 (diff)
downloadgentoo-e9ed63eb8a5df68ba376abe9dca396182bd52478.tar.gz
gentoo-e9ed63eb8a5df68ba376abe9dca396182bd52478.tar.bz2
gentoo-e9ed63eb8a5df68ba376abe9dca396182bd52478.zip
xfce-extra/xfce4-notifyd: Backport appinfo-related crash fix
Closes: https://bugs.gentoo.org/879115 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-notifyd')
-rw-r--r--xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch27
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4-r1.ebuild (renamed from xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild)9
2 files changed, 35 insertions, 1 deletions
diff --git a/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch b/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch
new file mode 100644
index 000000000000..5ca1cbda8e53
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/files/xfce4-notifyd-0.6.4-appinfo-crash.patch
@@ -0,0 +1,27 @@
+From ddf469fe567f1c2f17013f3baa9bd3721cdd32a5 Mon Sep 17 00:00:00 2001
+From: Guido Falsi <mad@madpilot.net>
+Date: Fri, 2 Sep 2022 21:24:34 +0200
+Subject: [PATCH] Fix segfault crash.
+
+---
+ common/xfce-notify-log.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/common/xfce-notify-log.c b/common/xfce-notify-log.c
+index d42dc1e..7ccfd42 100644
+--- a/common/xfce-notify-log.c
++++ b/common/xfce-notify-log.c
+@@ -149,7 +149,9 @@ notify_get_from_desktop_file (const gchar *desktop_file, const gchar *key)
+
+ match = matches[0];
+ appinfo = g_desktop_app_info_new (match[0]);
+- value = notify_read_from_desktop_file (g_desktop_app_info_get_filename (appinfo), key);
++ if (appinfo != NULL) {
++ value = notify_read_from_desktop_file (g_desktop_app_info_get_filename (appinfo), key);
++ }
+
+ for (gchar ***p = matches; *p != NULL; p++)
+ g_strfreev (*p);
+--
+GitLab
+
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4-r1.ebuild
index 103fa082ba4b..4d510c7de30a 100644
--- a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4.ebuild
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.6.4-r1.ebuild
@@ -6,7 +6,10 @@ EAPI=8
inherit xdg-utils
DESCRIPTION="Notification daemon for the Xfce desktop environment"
-HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-notifyd"
+HOMEPAGE="
+ https://docs.xfce.org/apps/notifyd/start
+ https://gitlab.xfce.org/apps/xfce4-notifyd/
+"
SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="GPL-2"
@@ -32,6 +35,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/${P}-appinfo-crash.patch
+)
+
src_install() {
default
find "${D}" -name '*.la' -delete || die