summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-07 21:57:10 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-07 21:57:10 +0100
commit2ee5a67a78a5ca508108c20e52b4c30aade6b561 (patch)
tree8e135697ee849fd9e1c43bcb56982eed3d9c81ec /xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.10.ebuild
parentgames-emulation/fceux: add 2.6.3 (diff)
downloadgentoo-2ee5a67a78a5ca508108c20e52b4c30aade6b561.tar.gz
gentoo-2ee5a67a78a5ca508108c20e52b4c30aade6b561.tar.bz2
gentoo-2ee5a67a78a5ca508108c20e52b4c30aade6b561.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.10.ebuild')
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.10.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.10.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.10.ebuild
new file mode 100644
index 000000000000..a1fa0070a58d
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.10.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ >=x11-libs/pango-1.44:=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/libxfce4ui-4.14:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-apps/help2man
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}