summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-26 22:54:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-26 22:54:11 +0200
commitedeb548edafa9dd92ba8bdd88845712ca376bbb9 (patch)
tree588825da1a71f8f27c0aabb2b74d1ebc3cb6ca90 /xfce-extra/xfce4-sensors-plugin
parentapp-benchmarks/stress-ng: fix compilation with glibc-2.34 (diff)
downloadgentoo-edeb548edafa9dd92ba8bdd88845712ca376bbb9.tar.gz
gentoo-edeb548edafa9dd92ba8bdd88845712ca376bbb9.tar.bz2
gentoo-edeb548edafa9dd92ba8bdd88845712ca376bbb9.zip
xfce-extra/xfce4-sensors-plugin: Bump to 1.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-sensors-plugin')
-rw-r--r--xfce-extra/xfce4-sensors-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.1.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-sensors-plugin/Manifest b/xfce-extra/xfce4-sensors-plugin/Manifest
index 201fd9183da6..1cee65559d4b 100644
--- a/xfce-extra/xfce4-sensors-plugin/Manifest
+++ b/xfce-extra/xfce4-sensors-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-sensors-plugin-1.3.95.tar.bz2 486771 BLAKE2B 130b38d30bcbb2e08ca167846f32ebc7e60ea2cd855ae0bcbcf82e8a73c9cdf04cd91da5c5e8e1a73c79b0d36e00366a37fa04cb40abc477df70dd2ee77d866f SHA512 265dec06bcd7a609b992e70273e8b11fdbaec41b0eb4dcb1b390e315b924743b3833b65fe2d237bb0b457e61943b97c065b34138216b171d111f5e923602642b
+DIST xfce4-sensors-plugin-1.4.1.tar.bz2 471543 BLAKE2B a5cc58c7c8a68b78dca7c810083daa69a43e265161e2dcfd2b99ee16fa40583c0e5a6f1e31cb6d3ad23f8a0cccacd52ca7d44623a32951b185614404f917c7a6 SHA512 d3f335e1f18fe748648be07ace6a88eb9f95222dd4d8dd4f6e5cbb3b7c69bd93b02fdbe12b9f08e65fbf7ba8461d7a685467f9e62c0682c85b3699fae5b7ed33
diff --git a/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.1.ebuild b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.1.ebuild
new file mode 100644
index 000000000000..c6f3e1ff121d
--- /dev/null
+++ b/xfce-extra/xfce4-sensors-plugin/xfce4-sensors-plugin-1.4.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for acpi, lm-sensors and hddtemp sensors"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-sensors-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+acpi hddtemp libnotify lm-sensors video_cards_nvidia"
+
+REQUIRED_USE="|| ( hddtemp lm-sensors acpi )"
+
+RDEPEND=">=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+ hddtemp? (
+ app-admin/hddtemp
+ || (
+ net-analyzer/openbsd-netcat
+ net-analyzer/netcat
+ )
+ )
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ lm-sensors? ( >=sys-apps/lm-sensors-3.1.0:= )
+ video_cards_nvidia? ( x11-drivers/nvidia-drivers[tools,static-libs] )"
+DEPEND=${RDEPEND}
+
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable lm-sensors libsensors)
+ $(use_enable hddtemp)
+ $(use_enable hddtemp netcat)
+ $(use_enable acpi procacpi)
+ $(use_enable acpi sysfsacpi)
+ $(use_enable video_cards_nvidia xnvctrl)
+ $(use_enable libnotify notification)
+ --disable-pathchecks
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}