summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-10-04 15:41:10 +0200
committerMichał Górny <mgorny@gentoo.org>2019-10-04 15:48:22 +0200
commitfefa0f38c414c5b5331e7977399968f4ef8969eb (patch)
tree27382c194978bf065813d32217fc59e2ba277afd /xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.1.ebuild
parentxfce-extra/xfce4-eyes-plugin: Bump to 4.5.0 (diff)
downloadgentoo-fefa0f38c414c5b5331e7977399968f4ef8969eb.tar.gz
gentoo-fefa0f38c414c5b5331e7977399968f4ef8969eb.tar.bz2
gentoo-fefa0f38c414c5b5331e7977399968f4ef8969eb.zip
xfce-extra/xfce4-wavelan-plugin: Bump to 0.6.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.1.ebuild')
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.1.ebuild b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.1.ebuild
new file mode 100644
index 000000000000..b0523fdc5a48
--- /dev/null
+++ b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A panel plug-in to display wireless interface statistics"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-wavelan-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux"
+
+COMMON_DEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/net-tools )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}