summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Tietz <christian.tietz@mailbox.org>2019-08-12 00:35:46 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-15 07:58:08 +0200
commit06a6e06cb0b2ab817ad873720a47c02cbbae81c4 (patch)
treec608d3371cca07036f87a87c36d27ef779e7867a /xfce-extra/xfce4-whiskermenu-plugin
parentdev-util/cucumber-rails: add 1.8.0 (diff)
downloadgentoo-06a6e06cb0b2ab817ad873720a47c02cbbae81c4.tar.gz
gentoo-06a6e06cb0b2ab817ad873720a47c02cbbae81c4.tar.bz2
gentoo-06a6e06cb0b2ab817ad873720a47c02cbbae81c4.zip
xfce-extra/xfce4-whiskermenu-plugin: Bump to 2.3.3, EAPI=7
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Christian Tietz <christian.tietz@mailbox.org> Closes: https://github.com/gentoo/gentoo/pull/12680 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/Manifest b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
index 4a176cc03e28..9a741b17fd83 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/Manifest
+++ b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-whiskermenu-plugin-2.3.2.tar.bz2 159652 BLAKE2B 4afb6b3ae039a4193e08d4b06130aa757d3c14123798afb360fb696679a3692d10c2de8a5aa2075711e06474380d61ab21fe3186546a9afb871a295811d70f1f SHA512 2b9557b29d1b30b5d46df5f182d64562873defd59cd36e6444da4b73bbdf3835cfb17101f11a3ac6e9f875a9dc4d51e2301a420a888bfa1d7fdc6ae715d92443
+DIST xfce4-whiskermenu-plugin-2.3.3.tar.bz2 160277 BLAKE2B c4c96175f1d8a7202e8a6d207dc113ec172493eb724f7da7ef18fa3de26e52c3b86bc0135ca8cb1e650a0e9d835e065b6baa18816dee7c90c4034dcfc9033639 SHA512 06e8c0ec623538103974c266c26b8efea94f97093324b5f55305ba6832a8c9eb7fa19c636249dffbc09ed4c7e3f543d338b2bd3455c14601237b2253683f5ac6
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
new file mode 100644
index 000000000000..482365c0e81b
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.3.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake-utils xdg-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libintl:=
+ x11-libs/gtk+:3
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}