summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-11-19 21:36:49 +0100
committerMichał Górny <mgorny@gentoo.org>2023-11-19 21:36:49 +0100
commit0d905b53b71dd78d7d3c2a13f1b2c818b6991f33 (patch)
tree7cbac2ee5805d11fd5ff2e95b391b764a3f3813e /xfce-extra
parentdev-python/scipy: Add ~ppc64 to 1.11.3-r1 (diff)
downloadgentoo-0d905b53b71dd78d7d3c2a13f1b2c818b6991f33.tar.gz
gentoo-0d905b53b71dd78d7d3c2a13f1b2c818b6991f33.tar.bz2
gentoo-0d905b53b71dd78d7d3c2a13f1b2c818b6991f33.zip
xfce-extra/xfce4-dict: Bump to 0.8.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-dict/Manifest1
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.8.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-dict/Manifest b/xfce-extra/xfce4-dict/Manifest
index 2bc5718f812b..9442703725e2 100644
--- a/xfce-extra/xfce4-dict/Manifest
+++ b/xfce-extra/xfce4-dict/Manifest
@@ -1 +1,2 @@
DIST xfce4-dict-0.8.5.tar.bz2 514096 BLAKE2B 5ababf17457fe972794e1aca0a4c031af8c3898e97d46d3d4ba26a0b24bcaa750255dbb084157525650f91a19de8aca9437fa662f70e2340d43b0ab6ae935ebb SHA512 4ff6e881c4dfec6cc6a2e9a33ccad1362d3304e58d91cc5da9305a937c7e3382d9c2ad3356d9e4d5f080d4368f7e0f3ceded1c2fbf18bca8ac7903310d22ffc3
+DIST xfce4-dict-0.8.6.tar.bz2 542993 BLAKE2B acf378e985c23d46b7dce1a1f0feb13b2b86a9a67d1b6123f0073530181ecd796c8d19de6bb488bac6e14176c36976e49158b990bf9fd6966553ea1ed8451d12 SHA512 bbb5926121e31c5adbd8f4c3ceb479759ee07b902e690245087213668fade48b92f9ffc7f4cabdfaa3ee1c02db8847468dd0bbd11e240017cd3c2b9901b81485
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.8.6.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.8.6.ebuild
new file mode 100644
index 000000000000..264838b8e419
--- /dev/null
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.8.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A dict.org querying application and panel plug-in for the Xfce desktop"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-dict/start
+ https://gitlab.xfce.org/apps/xfce4-dict/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.24.0
+ >=x11-libs/gtk+-3.22.0:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.10.0:=
+ >=xfce-base/libxfce4ui-4.12.0:=
+ >=xfce-base/xfce4-panel-4.10.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}