summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-28 09:39:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-28 09:42:20 +0100
commit24eab02ae88a997989c540f57cc675e3cfba836a (patch)
treed2d5d9b217c2639fd5a5bc263b86ef8db6a55c7e /xfce-extra
parentdev-python/importlib_resources: Bump to 4.1.1 (diff)
downloadgentoo-24eab02ae88a997989c540f57cc675e3cfba836a.tar.gz
gentoo-24eab02ae88a997989c540f57cc675e3cfba836a.tar.bz2
gentoo-24eab02ae88a997989c540f57cc675e3cfba836a.zip
xfce-extra/xfce4-verve-plugin: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-verve-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-verve-plugin/Manifest b/xfce-extra/xfce4-verve-plugin/Manifest
index 2b5830bbca14..bbe1e4828e96 100644
--- a/xfce-extra/xfce4-verve-plugin/Manifest
+++ b/xfce-extra/xfce4-verve-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-verve-plugin-2.0.0.tar.bz2 384165 BLAKE2B 7223a2f52574a41acb07ea777a00470a7b0aed027b1084f6fc706d6af07eceb801b15bf2bcdfb9988806f18189363e34f99f929911e23c7ed702ee94c1ca21d7 SHA512 b6be658f5996857e1c5696dc66f973fa5875ba95682297ad157e107abae821023cdf7101ba5f8e5358740549e392b76bf7d1dae252f43bf1a7e8716d798ed39a
+DIST xfce4-verve-plugin-2.0.1.tar.bz2 384412 BLAKE2B 3a0370b1027fef00d748de43bf420271e8d093a203a1c77dfbb8ecd093e139d35ce6f7d585558635b2f5566dc49d8c226c9d6ebe88e7a785ffeabe1a9c8f63eb SHA512 c8397bd833e2a2cf25d86bd9234bdbafed00ce0783273532a57e87a5182d26b3e84b402ed8c9fd9204d5d46fbca257fcf6601f279d9929d806a4c36338379876
diff --git a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild
new file mode 100644
index 000000000000..89349ae153f8
--- /dev/null
+++ b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A comfortable command line plugin for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ dev-libs/glib:2=
+ >=dev-libs/libpcre-5:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}