summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-12 13:51:09 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-12 15:20:34 +0200
commit28af458cf5bd870db8a40d783fa45a9f7d7e43af (patch)
tree7c2b1dbc3f05cf7979fa3c0c60e453ddf0184376 /xfce-extra
parentxfce-base/xfce4-appfinder: Bump to 4.14.0 (diff)
downloadgentoo-28af458cf5bd870db8a40d783fa45a9f7d7e43af.tar.gz
gentoo-28af458cf5bd870db8a40d783fa45a9f7d7e43af.tar.bz2
gentoo-28af458cf5bd870db8a40d783fa45a9f7d7e43af.zip
xfce-extra/thunar-volman: Bump to 0.9.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-volman/Manifest1
-rw-r--r--xfce-extra/thunar-volman/thunar-volman-0.9.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/thunar-volman/Manifest b/xfce-extra/thunar-volman/Manifest
index 1dd68cefec21..dd44f5087f5d 100644
--- a/xfce-extra/thunar-volman/Manifest
+++ b/xfce-extra/thunar-volman/Manifest
@@ -1,2 +1,3 @@
DIST thunar-volman-0.8.1.tar.bz2 474769 BLAKE2B 2bf6378b35f0cd868cc7363909cc5d54a997a5a69758a27d45640968e3ef8d7cb3f5af185d1a8f83e8593610490a8566742070808ab85810cd3411856aa0030a SHA512 a82c019b028277d97e7903dcbeaf4704cb7fc1e95b0ea18c6290a7a8581355691990cbdb5fa0c234ed5dd51c1ba7f1bca9a495e60f9f8597a993845481113bb6
DIST thunar-volman-0.9.4.tar.bz2 501493 BLAKE2B 788b881f40995e95fffcedd70c0c0ea66ec8f9a81386e103d41c853a2d24408d79be04053cf34fbb5a8a28a367713ccd63cc3eaf4e536ec71a3466edb8d387ae SHA512 e75d1d8a6094f9722e170f7dc2978a213b292225ec66cdb602c4a3a2b9dac07b5d5228c970c0a39f46f4f7a0197c089f7f930fbc24dfc202dbdc27501686fb2f
+DIST thunar-volman-0.9.5.tar.bz2 501846 BLAKE2B e64a1593551cb542461be54e7e0624a9e3a3f0db43df166f0922f79e031a0f85da3eb00289a8d30c427c5f6500a3e12b065a7fdf3f34e24d6e88d27be048669a SHA512 843ff1f55b68e6f584da29c2c6c91ed045c4e9ee05cb573db6a0192553cf05faefb4227359bd6ef306c2bbb94e2fe5357c07f70a0d170b35c48d3e9ebac7a9b9
diff --git a/xfce-extra/thunar-volman/thunar-volman-0.9.5.ebuild b/xfce-extra/thunar-volman/thunar-volman-0.9.5.ebuild
new file mode 100644
index 000000000000..854fba8adbb2
--- /dev/null
+++ b/xfce-extra/thunar-volman/thunar-volman-0.9.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+# CC for tvm-burn-cd.svg
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libnotify"
+
+COMMON_DEPEND=">=dev-libs/glib-2.30
+ virtual/libgudev:=
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/udev
+ >=xfce-base/thunar-1.6[udisks]"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}