summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-20 04:27:23 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-20 04:27:23 +0200
commit326f766dfe0d494a548ddbb120a3808c5de2d2d3 (patch)
tree4f454b4390175b51115eb9a37c6dc7b09dbb378f /xfce-extra
parentxfce-base/xfce4-appfinder: Bump to 4.19.0 (diff)
downloadgentoo-326f766dfe0d494a548ddbb120a3808c5de2d2d3.tar.gz
gentoo-326f766dfe0d494a548ddbb120a3808c5de2d2d3.tar.bz2
gentoo-326f766dfe0d494a548ddbb120a3808c5de2d2d3.zip
xfce-extra/xfce4-battery-plugin: Bump to 1.1.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index de3ed39423c3..b231a5c891dc 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-battery-plugin-1.1.4.tar.bz2 458485 BLAKE2B 5af18d0f8944afdc6c93852220cd87020d7ea18ce27e224def5ed71f3d9490e2e30982bbff322a76feb3d6464888a8cd64e40c9938484256432537ea1a150009 SHA512 6a59630800a79d2c62434c1c50f5d891ae9ebae48037ea0859d6edd66c856a76e6f11c6e8866ca3c94ae1e5b57bdba4e9fadd4bc92c7fcef278cd2f7b82203f2
+DIST xfce4-battery-plugin-1.1.5.tar.bz2 465191 BLAKE2B 6aa8f1d3cd3dbf3fe29fede154ad51c7cf521c04191699582678e930c2ff0a20c2f50bda22d9576b1f29b595767c5ee1ce4a7ef60cdf3fd69271796d2af8ae2e SHA512 e6e09a4839911dda50fe1fed100d5fd46f6da47e5042529c2cbffa5498babc838bed56178baa23d2162b70cd6e5f005276d4b9f1fc44a1891737c94c2bf525d0
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild
new file mode 100644
index 000000000000..36a3ac9eb607
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.5.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-battery-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-battery-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.16.0:3
+ >=xfce-base/libxfce4ui-4.14.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.14.0:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}