summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-09 16:54:05 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-09 18:09:01 +0200
commit3316c659c06e959e5fa121715c61ccab3a603e02 (patch)
tree0c8e09190ae362416c3f59524d64ad8b38589f78 /xfce-extra
parentmedia-gfx/xdot: Drop old versions (diff)
downloadgentoo-3316c659c06e959e5fa121715c61ccab3a603e02.tar.gz
gentoo-3316c659c06e959e5fa121715c61ccab3a603e02.tar.bz2
gentoo-3316c659c06e959e5fa121715c61ccab3a603e02.zip
xfce-extra/xfce4-time-out-plugin: Port to EAPI 7, off xfconf
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.2-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.2-r1.ebuild b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..6bb08dc9c8cf
--- /dev/null
+++ b/xfce-extra/xfce4-time-out-plugin/xfce4-time-out-plugin-1.0.2-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in to take periodical breaks from the computer"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-time-out-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.8:=
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.8:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}