summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2021-02-27 11:05:34 -0800
committerMichał Górny <mgorny@gentoo.org>2021-03-01 19:50:20 +0100
commit3c15659ba9428ee5ea9e77f8564c2c69e32e4343 (patch)
tree9bb228527e701782a01a0f7566efc90b30cbe944 /xfce-extra
parentdev-python/pillow: Stabilize 8.1.1 amd64, #773559 (diff)
downloadgentoo-3c15659ba9428ee5ea9e77f8564c2c69e32e4343.tar.gz
gentoo-3c15659ba9428ee5ea9e77f8564c2c69e32e4343.tar.bz2
gentoo-3c15659ba9428ee5ea9e77f8564c2c69e32e4343.zip
xfce-extra/xfce4-kbdleds-plugin: bump to 0.2.3
HOMEPAGE and SRC_URI changed to Github, but it appears (based on the Github username and a path component in the old SRC_URI) to be the same author. LICENSE changed to GPL-2+. The headers in the source files all include “or (at your option) any later version.” Both the GPL-2 and LGPL-2 texts are included in the repo. The main license grant text refers to GPL-2+ while the disclaimer of warranty text refers to the LGPL. Since the warranty sections of the GPL-2 and LGPL-2 are identical, it seems reasonable to mark the license as only GPL-2+. Signed-off-by: Christopher Head <chead@chead.ca> Bug: https://bugs.gentoo.org/732754 Closes: https://github.com/gentoo/gentoo/pull/19695 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-kbdleds-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-kbdleds-plugin/files/xfce4-kbdleds-plugin-0.2.3-xfce-4.16.patch44
-rw-r--r--xfce-extra/xfce4-kbdleds-plugin/metadata.xml3
-rw-r--r--xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.2.3.ebuild40
4 files changed, 88 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-kbdleds-plugin/Manifest b/xfce-extra/xfce4-kbdleds-plugin/Manifest
index df2602eb17e2..3203283f58c0 100644
--- a/xfce-extra/xfce4-kbdleds-plugin/Manifest
+++ b/xfce-extra/xfce4-kbdleds-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-kbdleds-plugin-0.0.6.tar.bz2 265889 BLAKE2B 1b166dce725f92fe05273d427dd4d185e6a240c984e4e2503f092af222e7a08b8697b8031804490322bb156bc5109c82f38273278fff185a9039b26334541ef2 SHA512 2cc48ec04d24ff55900c511c1fbe3ce1f7c45e59a30098a3b8af292ff5b219e7050e81d22f449f77ac79129b63db20ea61cb49730c5092583b935190149e127f
+DIST xfce4-kbdleds-plugin-0.2.3.tar.bz2 321690 BLAKE2B 847bbf675b97659c86c0668ab9ce96787866734377f3fdb49d4b5f18a3735cace66279783df92fe8cfff57ff05f4f09fa3fff23e0dc89f1b2d0fbd512e5089f5 SHA512 ddedaf430226f77d03f63f4dc31518184fd808d01c6049adbf41cacc2f46c78c3ce48c5a0450c200acda4a328d9716d54f7cc225913f4761a0526710b76f0cee
diff --git a/xfce-extra/xfce4-kbdleds-plugin/files/xfce4-kbdleds-plugin-0.2.3-xfce-4.16.patch b/xfce-extra/xfce4-kbdleds-plugin/files/xfce4-kbdleds-plugin-0.2.3-xfce-4.16.patch
new file mode 100644
index 000000000000..8b69a019a0ae
--- /dev/null
+++ b/xfce-extra/xfce4-kbdleds-plugin/files/xfce4-kbdleds-plugin-0.2.3-xfce-4.16.patch
@@ -0,0 +1,44 @@
+diff --git a/panel-plugin/kbdleds-dialogs.c b/panel-plugin/kbdleds-dialogs.c
+index 7f751f3ef446..7e4125f2be22 100644
+--- a/panel-plugin/kbdleds-dialogs.c
++++ b/panel-plugin/kbdleds-dialogs.c
+@@ -25,7 +25,7 @@
+ #include <gtk/gtk.h>
+
+ #include <libxfce4ui/libxfce4ui.h>
+-#include <libxfce4panel/xfce-panel-plugin.h>
++#include <libxfce4panel/libxfce4panel.h>
+
+ #include "kbdleds.h"
+ #include "kbdleds-dialogs.h"
+diff --git a/panel-plugin/kbdleds.c b/panel-plugin/kbdleds.c
+index 9c78d402b1c7..502a2885bcea 100644
+--- a/panel-plugin/kbdleds.c
++++ b/panel-plugin/kbdleds.c
+@@ -28,7 +28,7 @@
+
+ #include <gtk/gtk.h>
+ #include <libxfce4util/libxfce4util.h>
+-#include <libxfce4panel/xfce-panel-plugin.h>
++#include <libxfce4panel/libxfce4panel.h>
+
+ #include "kbdleds.h"
+ #include "kbdleds-dialogs.h"
+@@ -140,7 +140,7 @@ kbdleds_new (XfcePanelPlugin *plugin)
+ GtkWidget *label;
+
+ /* allocate memory for the plugin structure */
+- kbdleds = panel_slice_new0 (kbdledsPlugin);
++ kbdleds = g_slice_new0 (kbdledsPlugin);
+
+ /* pointer to plugin */
+ kbdleds->plugin = plugin;
+@@ -187,7 +187,7 @@ kbdleds_free (XfcePanelPlugin *plugin,
+ //g_free (kbdleds->setting1);
+
+ /* free the plugin structure */
+- panel_slice_free (kbdledsPlugin, kbdleds);
++ g_slice_free (kbdledsPlugin, kbdleds);
+
+ /* free the timeout */
+ if (timeoutId) {
diff --git a/xfce-extra/xfce4-kbdleds-plugin/metadata.xml b/xfce-extra/xfce4-kbdleds-plugin/metadata.xml
index 359901b31db4..c61af41106ed 100644
--- a/xfce-extra/xfce4-kbdleds-plugin/metadata.xml
+++ b/xfce-extra/xfce4-kbdleds-plugin/metadata.xml
@@ -5,4 +5,7 @@
<email>xfce@gentoo.org</email>
<name>XFCE Team</name>
</maintainer>
+ <upstream>
+ <remote-id type="github">oco2000/xfce4-kbdleds-plugin</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.2.3.ebuild b/xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.2.3.ebuild
new file mode 100644
index 000000000000..df771dd85935
--- /dev/null
+++ b/xfce-extra/xfce4-kbdleds-plugin/xfce4-kbdleds-plugin-0.2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in to show state of Caps, Num and Scroll Lock keys"
+HOMEPAGE="https://github.com/oco2000/xfce4-kbdleds-plugin"
+SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel"
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+# https://github.com/oco2000/xfce4-kbdleds-plugin/pull/7
+PATCHES=( "${FILESDIR}/${P}-xfce-4.16.patch" )
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}