summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-30 15:15:16 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-30 15:15:16 +0200
commit4bdf0b3d0f651eee092ad409b20d6c3285cda3e0 (patch)
treed6d3151d08101793eb660e8115d35672ea68c9af /xfce-extra
parentapp-emacs/webpaste: new package; add version 3.2.2 (diff)
downloadgentoo-4bdf0b3d0f651eee092ad409b20d6c3285cda3e0.tar.gz
gentoo-4bdf0b3d0f651eee092ad409b20d6c3285cda3e0.tar.bz2
gentoo-4bdf0b3d0f651eee092ad409b20d6c3285cda3e0.zip
xfce-extra/thunar-archive-plugin: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-archive-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/thunar-archive-plugin/Manifest b/xfce-extra/thunar-archive-plugin/Manifest
index 27b0b68ec787..e4297b2d8d4d 100644
--- a/xfce-extra/thunar-archive-plugin/Manifest
+++ b/xfce-extra/thunar-archive-plugin/Manifest
@@ -1 +1,2 @@
DIST thunar-archive-plugin-0.4.0.tar.bz2 350011 BLAKE2B aebe828396e75701b788dd22266ed154b3a8296b8f6a912fbd99d4ebda1db2ed2a5cbf957a381523194270b5f1ea8ae6af24ca61e35b3953de54b0477bffd6cf SHA512 6590d8765ac6eab14fae7758e4c47c66b52e79e2e4b01a86d25bd35492590925ca35e4bbade8a9d8f0c73386eaeda6863e2a7a39a2df2904404f7e2bfdd91a44
+DIST thunar-archive-plugin-0.5.0.tar.bz2 378749 BLAKE2B d420e121351fc78bd67880c89574a762dfd51949087cbde117c48cf8f879bf1c7416d960bf7d49bb704008a8dc10e1d87ecf43481f644f07bbadbc00d7348af8 SHA512 5a606f5102689e5e0fa051b25cae6f66248491aeab2c6402fd158151f9cbfab54ff4b61c36eab89fdf323b65065d955bdedd6760f32a5493179e92492ee1df37
diff --git a/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.0.ebuild b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.0.ebuild
new file mode 100644
index 000000000000..fd5d69ef3f4c
--- /dev/null
+++ b/xfce-extra/thunar-archive-plugin/thunar-archive-plugin-0.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Archive plug-in for the Thunar filemanager"
+HOMEPAGE="https://docs.xfce.org/xfce/thunar/archive"
+SRC_URI="https://archive.xfce.org/src/thunar-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/thunar-1.7:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}