summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-14 11:26:58 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-14 12:16:25 +0200
commit684f428db14fba604ecf2304fb15510df2188fed (patch)
tree3516a5d8c654a39f5115a1b68078326dff33b53b /xfce-extra
parentapp-emacs/pandoc-mode: remove Emacs version limit (diff)
downloadgentoo-684f428db14fba604ecf2304fb15510df2188fed.tar.gz
gentoo-684f428db14fba604ecf2304fb15510df2188fed.tar.bz2
gentoo-684f428db14fba604ecf2304fb15510df2188fed.zip
xfce-extra/xfce4-xkb-plugin: Bump to 0.8.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-xkb-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-xkb-plugin/Manifest b/xfce-extra/xfce4-xkb-plugin/Manifest
index b46ca40440ce..5b6b24bc34eb 100644
--- a/xfce-extra/xfce4-xkb-plugin/Manifest
+++ b/xfce-extra/xfce4-xkb-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-xkb-plugin-0.8.2.tar.bz2 868539 BLAKE2B 20a7a27903be434490b3328f04d57a4ceb505dc1b63e4c98d584c72e6ad0dbc742251c0d9f43ba1da869caa2924627b6cfddd969874a3f5fae8fbf90ef577da6 SHA512 3078c11e1c10195480251c455995e4342c27b06949fc754396824f03bed885f32078f4c1436d86782de031cf4f4f806b530ca53116d4bedb54dda19b68ec7062
+DIST xfce4-xkb-plugin-0.8.3.tar.bz2 864177 BLAKE2B 4c4c5ab781265e50ddb14210566f608e2798f881d4b06e7e8f121c466ea0eebb694cf394b0bec747b7a5f1f99962ee1d014f29f077ef877e8063c23934eff1b4 SHA512 02ae82a1e01b7cc54154545c6ff42a450a81ba44697620ebb716a663300ea08fbf6ccafc5fd4d710791f142e1c249f17b613d90ffd99025ad97dfa0230ee55b2
diff --git a/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
new file mode 100644
index 000000000000..cf690e000d06
--- /dev/null
+++ b/xfce-extra/xfce4-xkb-plugin/xfce4-xkb-plugin-0.8.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="XKB layout switching panel plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-xkb-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+DEPEND="
+ gnome-base/librsvg
+ x11-libs/gtk+:3
+ x11-libs/libwnck:3
+ x11-libs/libX11
+ >=x11-libs/libxklavier-5.3
+ xfce-base/garcon:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( x11-libs/libnotify )
+"
+RDEPEND="
+ ${DEPEND}
+ x11-apps/setxkbmap
+ >=xfce-base/xfce4-settings-4.11
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ $(use_enable libnotify)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}