summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-30 21:18:58 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-30 21:49:46 +0200
commit6cb98eac0d1d0cbb321be643e63e6e1a2af816c2 (patch)
treef9842f85ec21a7ca989d00a78e6037e441f36de6 /xfce-extra
parentnet-analyzer/tcptrace: Pull in Debian patch to replace private pcap_offline_r... (diff)
downloadgentoo-6cb98eac0d1d0cbb321be643e63e6e1a2af816c2.tar.gz
gentoo-6cb98eac0d1d0cbb321be643e63e6e1a2af816c2.tar.bz2
gentoo-6cb98eac0d1d0cbb321be643e63e6e1a2af816c2.zip
xfce-extra/xfce4-battery-plugin: Bump to 1.0.99, the GTK+3 pre-release
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.99.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index 52f962a4047d..33b36af8199f 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-battery-plugin-1.0.5.tar.bz2 403505 SHA256 f659b1af40ab72c93448affaa693ab551827a5600ce9b97a799b7c2419bdeb11 SHA512 f49f33178a771b952442f498cee2c722146c9982cb27453e6547a7c7838eaa0a22588a7d2a56f189f7e9e7b90ed7e5ac7a4e6cfee55dc5e43d32c5ef95b20062 WHIRLPOOL c23fff115afc9b5660ccf64332d71123d2e9161d9d79c5d66cc7aca12e5d904836b51e314053e0b571a044d70dbc64f0bb9592e79596fc9ee87f56376e120735
+DIST xfce4-battery-plugin-1.0.99.tar.bz2 415377 SHA256 d0cf48209b969510da82201b00f7c959105ff63b473fa4cd76e011c784626c41 SHA512 5c9de4d8f688f450f19bfe09ef410c7a8e3049e43ce613aa2dc250ea9097721e2839357e60d2926a4d2812ef7178d079ba7caa8c9899cfac9b78c018bbbf503d WHIRLPOOL 10643cfb4f0c5dd2c6e85fdc979c130a027b5fcf52224a15b957c733267479e8d33451e5e89ab5d1a4669fbcefd0ebc20d19735f180bc2f90f008514825e88b9
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.99.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.99.ebuild
new file mode 100644
index 000000000000..06113d665eec
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.0.99.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit linux-info xfconf
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="debug kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24:2=
+ >=x11-libs/gtk+-3.14:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}