summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-05 09:20:08 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-05 09:44:11 +0100
commit76496eab1951b7d01402033d85907b6bd533e73b (patch)
treedd8ae0acf3db8b10d9108ac5e3af36f0ab6d920d /xfce-extra
parentwww-client/firefox: add 97.0.2 (diff)
downloadgentoo-76496eab1951b7d01402033d85907b6bd533e73b.tar.gz
gentoo-76496eab1951b7d01402033d85907b6bd533e73b.tar.bz2
gentoo-76496eab1951b7d01402033d85907b6bd533e73b.zip
xfce-extra/xfce4-diskperf-plugin: Bump to 2.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-diskperf-plugin/Manifest b/xfce-extra/xfce4-diskperf-plugin/Manifest
index b246c12bd141..bb6632a87c7d 100644
--- a/xfce-extra/xfce4-diskperf-plugin/Manifest
+++ b/xfce-extra/xfce4-diskperf-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-diskperf-plugin-2.6.3.tar.bz2 384330 BLAKE2B c7e9d885f42d7f007570c54bd26c7b85aac1054cdb9a0ca0119267b89387ab731807090bea49f7be05b6bae314efd2a87845c4005cd7cf31aa41f1b2b5ee4519 SHA512 fb7ffeaca14f67bb8a2423529f7040d3e51a0184a552f4636acfb4aec914da5fef95db2c710cad8cb1a3b96ef9abc308ad072b03f6e2ccc49793c0edb73dc116
+DIST xfce4-diskperf-plugin-2.7.0.tar.bz2 342471 BLAKE2B c70d3468d1274632414064ae7709717c3e75fe4b9583007b85b66f711d86ff85cbe6819d9b6f606da3994deea190f4f2b4a932e48245a636a2706ee7caededb3 SHA512 8d9dde5534ff2ff99955e7d19b9fd1a0ca6e481f978462578c246c30febc9c2d16c97362014c05b53bd2e895199dbfaa2bdee459b84de3df94f86791d9b07b4f
diff --git a/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.0.ebuild b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.0.ebuild
new file mode 100644
index 000000000000..569b0326b740
--- /dev/null
+++ b/xfce-extra/xfce4-diskperf-plugin/xfce4-diskperf-plugin-2.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for disk usage and performance statistics"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-diskperf-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.16.0:3
+ >=xfce-base/libxfce4ui-4.14:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.14:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.14:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}