summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-28 14:02:18 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-28 14:07:07 +0100
commit79283ef172f352b7317ff0e6a21c3ba3c837663e (patch)
tree87a940e6b3ec45290baeb16a7bd50dbe088057a7 /xfce-extra
parentdev-libs/libgit2: Remove 1.6.1 (diff)
downloadgentoo-79283ef172f352b7317ff0e6a21c3ba3c837663e.tar.gz
gentoo-79283ef172f352b7317ff0e6a21c3ba3c837663e.tar.bz2
gentoo-79283ef172f352b7317ff0e6a21c3ba3c837663e.zip
xfce-extra/xfce4-notifyd: Bump to 0.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest1
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.2.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index 03f96542d3d2..74889b08fd0c 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-notifyd-0.6.5.tar.bz2 572193 BLAKE2B 498c8eecfd884aa04230fea2ecca3b663f0d6b59b549cc5a56d43ac20a17d4f15a1bd1e3ce8d1681de7307d569096bbbbe169ada447d41f7889daad5a35c8a8f SHA512 9953dd456520bd80e0d48da013703d7b976f953b9b41cd55f3ac236a74c55277d04f38a092e2a9024cd67cbcde3f3989daadf6b4f41e57c7e005c20f4acdf1ac
DIST xfce4-notifyd-0.8.0.tar.bz2 612641 BLAKE2B 4a368ba2dc8769586d6496ced8116a82e2ef548aa1e99ceb6066223a8c5a215089aed612909301d4bdc110d8172aae3274a988e4066b0b8d3d2fbd9135f8e373 SHA512 3b53036105fc194f87a4a76d5c5c578d0435bacf0fc10b5d0eeba37230cd76c9ce56cd30c840ee1d47baedffb1f1c1f2b8c88a0d6ca36207f0596ebc6ba75271
DIST xfce4-notifyd-0.8.1.tar.bz2 548158 BLAKE2B d512642d93e486aaec740eaa3b9b7aaa5875dfa6a16c328af8318d616cd3acd2bb891747782431be6237fe3090b80fc9d158866deccef1d99a3e6bf16fbb964b SHA512 555261a5931030e50686c4fb86fe62c5455ecba3ed6251851e0fae8652fbc85cb3c4fff3444a3dd6df3d9c44955d4f3049720c04635560170e3eb2c98aa95122
+DIST xfce4-notifyd-0.8.2.tar.bz2 684013 BLAKE2B ffb5e6ae171db83abeeebd375cbabb73b9a4f0e7d9135593ad2a3bf4c76b2080ce40134922ad1e4d11456166cc9a00cbfda6ee571c0934afc314451153dc6d75 SHA512 8da4bc1f81c1baa91367ba508be87e2bac71180734062cdcb308076acf97a5ccb52382b7e1bd031750253dda6a69882eb92f4679220bb042426092a47eb8c7e0
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.2.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.2.ebuild
new file mode 100644
index 000000000000..c81204b5a186
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/notifyd/start
+ https://gitlab.xfce.org/apps/xfce4-notifyd/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="sound wayland X"
+
+DEPEND="
+ >=dev-db/sqlite-3.34:3
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/gtk+-3.22:3[wayland?,X?]
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.14.0:=
+ >=xfce-base/xfconf-4.10:=
+ sound? (
+ >=media-libs/libcanberra-0.30[gtk3]
+ )
+ wayland? (
+ >=gui-libs/gtk-layer-shell-0.7.0
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable wayland gdk-wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X gdk-x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}