summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-12 10:45:36 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-12 10:48:58 +0100
commit7d32ccdd5d0d3d769b0f400cd3e9349be717601e (patch)
tree1817533193aff6481cd67c5b2cbb388e6c9a84c0 /xfce-extra
parentapp-text/openjade: Fix build with autoconf-2.70 (diff)
downloadgentoo-7d32ccdd5d0d3d769b0f400cd3e9349be717601e.tar.gz
gentoo-7d32ccdd5d0d3d769b0f400cd3e9349be717601e.tar.bz2
gentoo-7d32ccdd5d0d3d769b0f400cd3e9349be717601e.zip
xfce-extra/xfce4-cpufreq-plugin: Bump to 1.2.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpufreq-plugin/Manifest b/xfce-extra/xfce4-cpufreq-plugin/Manifest
index 08f42d86c07c..f221f7022642 100644
--- a/xfce-extra/xfce4-cpufreq-plugin/Manifest
+++ b/xfce-extra/xfce4-cpufreq-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-cpufreq-plugin-1.2.2.tar.bz2 408480 BLAKE2B da6f38a57126b8ad06dd77c9a1f09ffee78e58b390b53b5020af8da403b51f20ed8965b9d0bd0da2add993228d19ec9fcaa15ea4c22b42011140a8bfdb440dfa SHA512 b0cab40fa0e6cdbb59606d7712b1b1479e4a1e8ca1aa5a59d43fc863ac10eee6477461c827805d7544db49fa6e821f0351973fe650e2ef1520ddcadcbbde096e
+DIST xfce4-cpufreq-plugin-1.2.3.tar.bz2 415151 BLAKE2B 5c3c1298c5dc0562f4daf8df9c4f9e0d26b638f85efc5ec35d8edc08bb54a8de46b5af98c603fad6042eca0353419ae4f55cb642dcac7e3ef47509fbb712d58f SHA512 e8e9d705f304681253b6e8fb7ff8724dc7c339fda750c2fb7f05dc4f295b483679c0e2884e508c108ca9018499b50f4ff48a7d4dae5ef7c8ab78f0018f1ef959
diff --git a/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild
new file mode 100644
index 000000000000..3bf59fb4081e
--- /dev/null
+++ b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plugin for showing information about cpufreq settings"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}