summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-29 07:06:42 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-29 07:06:42 +0200
commit8029a1c5b4cbcb45a8e2cb8b926f5ec44effb05d (patch)
tree1b47e17d39ebf4da0f524e930fb3a4b86e412735 /xfce-extra
parentxfce-base/xfce4-panel: Bump to 4.19.1 (diff)
downloadgentoo-8029a1c5b4cbcb45a8e2cb8b926f5ec44effb05d.tar.gz
gentoo-8029a1c5b4cbcb45a8e2cb8b926f5ec44effb05d.tar.bz2
gentoo-8029a1c5b4cbcb45a8e2cb8b926f5ec44effb05d.zip
xfce-extra/xfce4-pulseaudio-plugin: Bump to 0.4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/metadata.xml2
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.6.ebuild77
3 files changed, 80 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/Manifest b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
index ba9806d3853e..da1f2ab03549 100644
--- a/xfce-extra/xfce4-pulseaudio-plugin/Manifest
+++ b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-pulseaudio-plugin-0.4.5.tar.bz2 394671 BLAKE2B facd79419b36741791b91d76da0212a99dfd2e807eedac691a5978b85365052702797cf67d2f0f8af294e9c0141fcedad49a92595acd4bbeadbf470889d7e16b SHA512 9250189af2d40f9b87687ef15e37983a95f797c2ba0aaa18cb8e510b7b1caff7f762a18db4e5a3780001b5cd46e00849d427801e14854c45e849c5d014a1375b
+DIST xfce4-pulseaudio-plugin-0.4.6.tar.bz2 422590 BLAKE2B 966dcc87c99888fb4b83901a4059ffa05bbc24707de0d32efd3c8f902f3f92277d13d9d9e8ae7475259b84f9a9a585336ab2f26d97ebf01f5031ede101335ad8 SHA512 b50193837a89c9adf8bfdd6c51cb872f8153448d71326ecd38171774164890436402d0041f98a79dc35a4523bfbd63dc4694f7ea13d4f8e38e98626280dd5127
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/metadata.xml b/xfce-extra/xfce4-pulseaudio-plugin/metadata.xml
index fceb4d4df330..06d056085482 100644
--- a/xfce-extra/xfce4-pulseaudio-plugin/metadata.xml
+++ b/xfce-extra/xfce4-pulseaudio-plugin/metadata.xml
@@ -10,6 +10,8 @@
<pkg>dev-libs/keybinder</pkg>.</flag>
<flag name="libcanberra">Enable sound event support using
<pkg>media-libs/libcanberra</pkg></flag>
+ <flag name="libxfce4windowing">Enable experimental support for raising media
+ player windows using <pkg>xfce-base/libxfce4windowing</pkg>.</flag>
<flag name="wnck">Enable experimental support for raising media
player windows using <pkg>x11-libs/libwnck</pkg>.</flag>
</use>
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.6.ebuild b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.6.ebuild
new file mode 100644
index 000000000000..654186fda701
--- /dev/null
+++ b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.6.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A panel plug-in for PulseAudio volume control"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~loong ~riscv ~x86"
+# TODO: remove wnck when libxfce4windowing is ready to go stable
+IUSE="+keybinder libcanberra libnotify libxfce4windowing wnck"
+REQUIRED_USE="?? ( libxfce4windowing wnck )"
+
+DEPEND="
+ >=dev-libs/glib-2.44.0
+ media-sound/pulseaudio:=[glib]
+ >=x11-libs/gtk+-3.20.0:3
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.9.0:=
+ >=xfce-base/xfce4-panel-4.11.0:=
+ >=xfce-base/xfconf-4.6.0:=
+ keybinder? ( dev-libs/keybinder:3 )
+ libcanberra? ( media-libs/libcanberra )
+ libnotify? ( x11-libs/libnotify )
+ libxfce4windowing? ( xfce-base/libxfce4windowing:= )
+ wnck? ( x11-libs/libwnck:3 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable keybinder)
+ $(use_enable libcanberra)
+ $(use_enable libnotify)
+ $(use_enable libxfce4windowing)
+ $(use_enable wnck)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+
+ if ! has_version media-sound/pavucontrol; then
+ elog "For the 'audio mixer...' shortcut to work, you need to install"
+ elog "an external mixer application. Please either install:"
+ elog
+ elog " media-sound/pavucontrol"
+ elog
+ elog "or specify another application to use in the 'Properties' dialog."
+ fi
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}