summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-18 11:58:04 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-18 16:03:20 +0100
commit9616de3ac51f083f91b4f0d2fe8d30333b166939 (patch)
treec37668ec6d8e653f6fc6ccc78fae4dfad5170c69 /xfce-extra
parentllvm.org.eclass: 16.0.0 has prebuilt manpages (diff)
downloadgentoo-9616de3ac51f083f91b4f0d2fe8d30333b166939.tar.gz
gentoo-9616de3ac51f083f91b4f0d2fe8d30333b166939.tar.bz2
gentoo-9616de3ac51f083f91b4f0d2fe8d30333b166939.zip
xfce-extra/xfce4-notes-plugin: Bump to 1.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-notes-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notes-plugin/Manifest b/xfce-extra/xfce4-notes-plugin/Manifest
index be9d707eb6c6..4376f795adbe 100644
--- a/xfce-extra/xfce4-notes-plugin/Manifest
+++ b/xfce-extra/xfce4-notes-plugin/Manifest
@@ -1 +1,2 @@
+DIST xfce4-notes-plugin-1.10.0.tar.bz2 492901 BLAKE2B 4b4724bf767e61b7c73ddeda71d4097751786d60335947d233e78fb8967ee9302d55a7cc259be4dbf2f8122d33a108769fdccdaf77f8fd4b50789196794e0b91 SHA512 4c050a95f879f0ba5e28662853ab764a14fbcef513e037bfdef1e3cae91b504d0c55eb0b533098589cf568c8e6e6e3ec2dec0841eb54c99c50105f6fff55a447
DIST xfce4-notes-plugin-1.9.0.tar.bz2 502606 BLAKE2B 2b1b2dd97301ab57363aeaa8a373c62a9e9c14bdc1eb7dd6355bb096728b05e5bee08ce8a5922c2a93f1c2b7fa7197f8aa3fb0c2a96d5eb71a7002c22eb8d13c SHA512 32ee410fa9d4dff4f73a844ac53024c39a884b48cee32faf14c1ed75200f912bd4e51a1fe3305deea9ec98a617b63a65e271437b09cb9b664498746a8095f4a1
diff --git a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild
new file mode 100644
index 000000000000..2caea09923fc
--- /dev/null
+++ b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.10.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 panel sticky notes plugin"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-notes-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-notes-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}