summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-11-03 17:31:41 +0100
committerMichał Górny <mgorny@gentoo.org>2019-11-03 17:38:34 +0100
commit982d77e264b1e29694b370578fde0d0d744a8db7 (patch)
treed92dc92dc11d87e15649629f0a068a9fca280aea /xfce-extra
parentx11-plugins/wmbattery: 2.54 bump (diff)
downloadgentoo-982d77e264b1e29694b370578fde0d0d744a8db7.tar.gz
gentoo-982d77e264b1e29694b370578fde0d0d744a8db7.tar.bz2
gentoo-982d77e264b1e29694b370578fde0d0d744a8db7.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest1
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index a4ca918492df..4d113ccfb7a6 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1 +1,2 @@
DIST xfce4-screenshooter-1.9.6.tar.bz2 529233 BLAKE2B db314b3b451c3f560d8068932b21049f3e9587f8e329b1efb08e25227ab812c15b76a9d9a5bd3ffa1b4663ec81508f6cda2b6d31054b72d7487a111477962a62 SHA512 17d4afb346f09f97225c0fe65ed2389733e98d58729f15f7ec2b601682d7e15a6d9c67b85840593c17298fc32c250d8eb2e8d349ccd355507f4c18b5e312ae35
+DIST xfce4-screenshooter-1.9.7.tar.bz2 536583 BLAKE2B de6376b68a7936f7ea22762449389ddd8ae1bf29f5fb062054691e4dc3f19471b63ef6201e813624cf2ec34c565ec0ac0d1de9db7d1b86296c736def5ab5023e SHA512 364594bd00172f0becb85f8643e4106b4a7b71ac5dad765850f54de011a77175801bd9e7eaab6a8bbb3b1353299fdfa25cc0a4a52d49017f9b51330377eb9add
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.7.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.7.ebuild
new file mode 100644
index 000000000000..7deaa2620378
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}