summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-25 00:05:18 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-25 00:08:20 +0100
commitbb716f672957a8ef9b2f9aa552e1428990f80013 (patch)
tree4b8191eb945de9bec426734be23f270c1c350d68 /xfce-extra
parentxfce-extra/xfce4-wavelan-plugin: Bump to 0.6.2 (diff)
downloadgentoo-bb716f672957a8ef9b2f9aa552e1428990f80013.tar.gz
gentoo-bb716f672957a8ef9b2f9aa552e1428990f80013.tar.bz2
gentoo-bb716f672957a8ef9b2f9aa552e1428990f80013.zip
xfce-extra/xfce4-whiskermenu-plugin: Bump to 2.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.5.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/Manifest b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
index a6119a60eb0f..385fb969d5f0 100644
--- a/xfce-extra/xfce4-whiskermenu-plugin/Manifest
+++ b/xfce-extra/xfce4-whiskermenu-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-whiskermenu-plugin-2.4.6.tar.bz2 173341 BLAKE2B 03d6ddbe72bf6de6713643bc9df4a6b824f5c7d3792ca8dc73552fa4b0c717fa719f56a4b9fa30c5d435c0f923e7f0260a330f883c9140762338908b586e3137 SHA512 9e947b73735549d81110323bfd7d6f29c91653b12e1aa616b9ca6f0ff99c8a7948ca383422d7b2aa0ac35297488fda6edc699ae4f72883539d6311672818b62c
+DIST xfce4-whiskermenu-plugin-2.5.0.tar.bz2 174639 BLAKE2B 02a3007f06d9d5ffab09fd027d913e7f8667fda1c276170dc69e766b1cce15e108d6486f7ca3285942b327412224f78b302f251719a4a84f62bb101f852cf369 SHA512 84f9ef9963e07b5489244b5283b371e2e405f4b280fa2884aa8b3c6a7358578064a227827a7d19b4ab9d72f9fd2016fa24a16b1b3f1f964df4d9d6d2ac2bcf72
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.5.0.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.5.0.ebuild
new file mode 100644
index 000000000000..38cde10a0586
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.5.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin/"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libintl
+ x11-libs/gtk+:3
+ xfce-base/exo:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:=
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ -DENABLE_LINK_TIME_OPTIMIZATION=OFF
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}