summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 09:01:23 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 09:01:23 +0100
commitc3e5de21e8e5dd21559d97c2fddcf795a14f96bb (patch)
treee438ec0317333069f1502eaa41c9659e30765753 /xfce-extra
parentxfce-base/xfdesktop: Bump to 4.16.0 (diff)
downloadgentoo-c3e5de21e8e5dd21559d97c2fddcf795a14f96bb.tar.gz
gentoo-c3e5de21e8e5dd21559d97c2fddcf795a14f96bb.tar.bz2
gentoo-c3e5de21e8e5dd21559d97c2fddcf795a14f96bb.zip
xfce-extra/thunar-volman: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/thunar-volman/Manifest1
-rw-r--r--xfce-extra/thunar-volman/thunar-volman-4.16.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/thunar-volman/Manifest b/xfce-extra/thunar-volman/Manifest
index d98d2bbd619c..ead2c480421d 100644
--- a/xfce-extra/thunar-volman/Manifest
+++ b/xfce-extra/thunar-volman/Manifest
@@ -1,2 +1,3 @@
DIST thunar-volman-0.9.5.tar.bz2 501846 BLAKE2B e64a1593551cb542461be54e7e0624a9e3a3f0db43df166f0922f79e031a0f85da3eb00289a8d30c427c5f6500a3e12b065a7fdf3f34e24d6e88d27be048669a SHA512 843ff1f55b68e6f584da29c2c6c91ed045c4e9ee05cb573db6a0192553cf05faefb4227359bd6ef306c2bbb94e2fe5357c07f70a0d170b35c48d3e9ebac7a9b9
DIST thunar-volman-4.15.1.tar.bz2 497217 BLAKE2B 2b98fc4699e82b3f9e60366840b3ba8dd7eb7a7a183ce06c29b2cb5f9fa48701e1ba795a33123032d53107717b514278d076f19e015b4fb7fcbf63c7cdcee2ed SHA512 9c0fb92200aea8109fe0aa9808bd0effe2f6c2def316193812a91137d85801227d0fbbca5ee5da659f718734e7fe254546e992d849702a2d04c345c18e97785c
+DIST thunar-volman-4.16.0.tar.bz2 501194 BLAKE2B 3d2fce7bb9a52a950ab84fa9986387af01d7d55864bd8fc1a3051ab406c99648b4ba21d018e806baa07ec1ac7e2bc798eb402b1c0e115e52b58ccdbda0ca4c5f SHA512 33b7561e55491b793aa634dfa0b108788286e6b7a2f60a781b8ba10f73de74630520736ae99c4db66ae2da562a82bb1a6bdacd8307d6d452f26e647da6471af8
diff --git a/xfce-extra/thunar-volman/thunar-volman-4.16.0.ebuild b/xfce-extra/thunar-volman/thunar-volman-4.16.0.ebuild
new file mode 100644
index 000000000000..9e3e1ee1be4d
--- /dev/null
+++ b/xfce-extra/thunar-volman/thunar-volman-4.16.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Daemon that enforces volume-related policies"
+HOMEPAGE="https://goodies.xfce.org/projects/thunar-plugins/thunar-volman"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+# CC for tvm-burn-cd.svg
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libnotify"
+
+DEPEND=">=dev-libs/glib-2.50
+ dev-libs/libgudev:=
+ >=x11-libs/gtk+-3.20:3
+ >=xfce-base/exo-0.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+RDEPEND="${DEPEND}
+ virtual/udev
+ >=xfce-base/thunar-1.6[udisks]"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}