summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-09 22:16:14 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-09 22:16:14 +0100
commitd22b4a63a75c56117c517cdc6402dabe7b9918e8 (patch)
treeeb166c049f37c304dccd531da4b7654725bd0bd4 /xfce-extra
parentapp-text/epstool: respect CC. (diff)
downloadgentoo-d22b4a63a75c56117c517cdc6402dabe7b9918e8.tar.gz
gentoo-d22b4a63a75c56117c517cdc6402dabe7b9918e8.tar.bz2
gentoo-d22b4a63a75c56117c517cdc6402dabe7b9918e8.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.10.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index e79eeae0553a..26cd1aa1751a 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-weather-plugin-0.10.1.tar.bz2 3026945 BLAKE2B 511427d430b696983855687db12ef8877eabc6a0e2518f511e9f90286b08fcf8b52da10bf6ba7b435c069d5018b653c2c7703e8b9ec3f858251ad9c949acb760 SHA512 14fd17da60b0ac76dd0f8e1b7858e8cef57c5168b7467412e1d45ae91e44858c7619cdca2ee59e242d2888038d458faa7580bf02d1cad3371ec80acc9012f569
+DIST xfce4-weather-plugin-0.10.2.tar.bz2 3049859 BLAKE2B 92e406a77f3538cfc9f5b23b7eb749df0593a4eb50eee6b7d589f00d3f30ce64a58557167189f0306a9079f7ff3ad09c8f67a822b63360ee45d35854b8e55704 SHA512 77df6d10772e47fc6b3cf4db2396b8c6ad87b6b3afb59b2a256d4c52c9f69db30039ee8c6d7b3fbabd613815cad284ecdf7b267293de7ebee76faaa583d89a11
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.2.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.2.ebuild
new file mode 100644
index 000000000000..cf19f7d52b16
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.42
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.42[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}