summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-13 21:11:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-13 21:11:33 +0100
commitd5c87bed34e1a25c1f1aa34a840ffed6c29593a8 (patch)
treea2323842a5b1f746ac2be5fed609045f54daaf4a /xfce-extra
parentnet-mail/courier-imap: fix conflict with maildrop (diff)
downloadgentoo-d5c87bed34e1a25c1f1aa34a840ffed6c29593a8.tar.gz
gentoo-d5c87bed34e1a25c1f1aa34a840ffed6c29593a8.tar.bz2
gentoo-d5c87bed34e1a25c1f1aa34a840ffed6c29593a8.zip
xfce-extra/xfce4-notes-plugin: Bump to 1.11.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-notes-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.0.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notes-plugin/Manifest b/xfce-extra/xfce4-notes-plugin/Manifest
index 16bd30f2b0a3..a6fc62e1c5ba 100644
--- a/xfce-extra/xfce4-notes-plugin/Manifest
+++ b/xfce-extra/xfce4-notes-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-notes-plugin-1.10.0.tar.bz2 492901 BLAKE2B 4b4724bf767e61b7c73ddeda71d4097751786d60335947d233e78fb8967ee9302d55a7cc259be4dbf2f8122d33a108769fdccdaf77f8fd4b50789196794e0b91 SHA512 4c050a95f879f0ba5e28662853ab764a14fbcef513e037bfdef1e3cae91b504d0c55eb0b533098589cf568c8e6e6e3ec2dec0841eb54c99c50105f6fff55a447
+DIST xfce4-notes-plugin-1.11.0.tar.bz2 524627 BLAKE2B f2d09bb460683169f73e35c7bdb7be0273acfd3a7ecac04bedaec6e4b91aeedc3400eaa10b08a5b632f845afa647851417bb2b5b3426360d0808bcc9bd733696 SHA512 3644049bb2aa77bbed5b391f47d67dbf6528cb535448287a28a011d78a6fb31971a3556fe37ad380858d2b561ef67fee2bc93c4ed0c19c75c564d832cd4d47f1
diff --git a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.0.ebuild b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.0.ebuild
new file mode 100644
index 000000000000..85fe6af099ee
--- /dev/null
+++ b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 panel sticky notes plugin"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-notes-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-notes-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.30:2
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}