summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-11 09:30:19 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-11 13:47:01 +0100
commite3de541e41967442c4302e5ead98b877ddd50170 (patch)
tree5d0777d4570e17fde086356509c0d282195f358e /xfce-extra
parentdev-libs/libclc: Add 17.0.0_pre20230211 snapshot (diff)
downloadgentoo-e3de541e41967442c4302e5ead98b877ddd50170.tar.gz
gentoo-e3de541e41967442c4302e5ead98b877ddd50170.tar.bz2
gentoo-e3de541e41967442c4302e5ead98b877ddd50170.zip
xfce-extra/xfce4-notifyd: Bump to 0.8.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-notifyd/Manifest1
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notifyd/Manifest b/xfce-extra/xfce4-notifyd/Manifest
index a24d460207ec..cdb7deea007a 100644
--- a/xfce-extra/xfce4-notifyd/Manifest
+++ b/xfce-extra/xfce4-notifyd/Manifest
@@ -1,3 +1,4 @@
DIST xfce4-notifyd-0.6.5.tar.bz2 572193 BLAKE2B 498c8eecfd884aa04230fea2ecca3b663f0d6b59b549cc5a56d43ac20a17d4f15a1bd1e3ce8d1681de7307d569096bbbbe169ada447d41f7889daad5a35c8a8f SHA512 9953dd456520bd80e0d48da013703d7b976f953b9b41cd55f3ac236a74c55277d04f38a092e2a9024cd67cbcde3f3989daadf6b4f41e57c7e005c20f4acdf1ac
DIST xfce4-notifyd-0.7.2.tar.bz2 576257 BLAKE2B 69e0ac8fdbabc5c27788f0854e4fc35cd837eaba9632d84c9acbebe088d1c111723c2b763b6da29c69cb3e9dec925581bc4b12eeb58d3e0ecd3a065db4e4f919 SHA512 7a2a162db82f7760a455c32c5a5dc25eba6f747bb76da56bc49f5c37e1386416496fa7bc51fe010fe403e958a8ab665ae7359ed334589b0b55942dcccd370894
DIST xfce4-notifyd-0.7.3.tar.bz2 587185 BLAKE2B 42da6227d59d97c0693d27ba6ca682f59c0625587f3f115a8f548349df156dc012e555bd6b3eecbf792eb3b6aa2d86d99895a1d0987a2da581928b1c2c54a987 SHA512 525fcf5dfa8c4a2bf48b4276b19f5fd1d5010bdeacd52f6d9189aabf1d5fe2a79efa542796c62d62c6a7bfc83d7eddf3ed671fa171be96c255907b7c7f599bee
+DIST xfce4-notifyd-0.8.0.tar.bz2 612641 BLAKE2B 4a368ba2dc8769586d6496ced8116a82e2ef548aa1e99ceb6066223a8c5a215089aed612909301d4bdc110d8172aae3274a988e4066b0b8d3d2fbd9135f8e373 SHA512 3b53036105fc194f87a4a76d5c5c578d0435bacf0fc10b5d0eeba37230cd76c9ce56cd30c840ee1d47baedffb1f1c1f2b8c88a0d6ca36207f0596ebc6ba75271
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.0.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.0.ebuild
new file mode 100644
index 000000000000..35fa954a9295
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.8.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/notifyd/start
+ https://gitlab.xfce.org/apps/xfce4-notifyd/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="sound wayland X"
+
+DEPEND="
+ >=dev-db/sqlite-3.34:3
+ >=dev-libs/glib-2.68.0:2
+ >=x11-libs/gtk+-3.22:3[wayland?,X?]
+ >=x11-libs/libnotify-0.7
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.10:=
+ sound? (
+ >=media-libs/libcanberra-0.30[gtk3]
+ )
+ wayland? (
+ >=gui-libs/gtk-layer-shell-0.7.0
+ )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable wayland gdk-wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X gdk-x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}