summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-02 07:53:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-02 08:13:16 +0100
commitfb38c3becc50948e5c78e21e11a5c1b4e957a699 (patch)
tree0eca1210c418d966ad718684ab20e5d2268044eb /xfce-extra
parentxfce-extra/xfce4-cpufreq-plugin: Bump to 1.2.7 (diff)
downloadgentoo-fb38c3becc50948e5c78e21e11a5c1b4e957a699.tar.gz
gentoo-fb38c3becc50948e5c78e21e11a5c1b4e957a699.tar.bz2
gentoo-fb38c3becc50948e5c78e21e11a5c1b4e957a699.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 4a8110a634ee..68e4a3dbaec4 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-cpugraph-plugin-1.2.5.tar.bz2 455357 BLAKE2B 8408338e7bd858940b1c8b25d8c5f622e72bbbcd61a5b96d44a9c4a88438fac476d1911cbf65f42b8bca9c478e7703cbc2e6ce2668d1b5ef9cd4d68076df6113 SHA512 1a0b362afa2dcae30721dc468e31949e4edfe20f5e1063603111d0cd7fcbd3460f14d7ffd30ae1d687400661c37a51a9c1b2f7abedea6c9e9888e93fbbb56d4a
+DIST xfce4-cpugraph-plugin-1.2.6.tar.bz2 458058 BLAKE2B 4cd7c9734a52b39d0606f25d5ae559230819e5672b6fe8fb4f19ed5afcf9a446790fe38753ef294ae99767bf06ae9ae08ebd85d66a83dcfb675d945ae2771d00 SHA512 6205a0a7616b0dc5de3cdeb79a5148ee775b426a16b52c491129f74104ab224ec3b29b042a3c8ee05b77cc8775c83d75a8312b96a71504cde50dc257e8354857
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild
new file mode 100644
index 000000000000..f47b3c810542
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}