summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch40
-rw-r--r--dev-python/httpauth/httpauth-0.3-r1.ebuild12
2 files changed, 50 insertions, 2 deletions
diff --git a/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch b/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch
new file mode 100644
index 000000000000..5cb607c2bb4c
--- /dev/null
+++ b/dev-python/httpauth/files/httpauth-0.3-remove-nose-dependency.patch
@@ -0,0 +1,40 @@
+commit d57060ebaeca8cd38e03cc64f9ee0996e83b50a9
+Author: Jonas Haag <jonas@lophus.org>
+Date: Thu Apr 21 08:58:36 2022 +0200
+
+ Move CI to GHA (#3)
+
+--- a/tests.py
++++ b/tests.py
+@@ -10,7 +10,7 @@ except ImportError: # Python 2
+
+ from httpauth import DictHttpAuthMiddleware, DigestFileHttpAuthMiddleware, md5_str
+
+-from nose.tools import raises
++import pytest
+
+
+ def parse_dict_header(value):
+@@ -121,16 +121,16 @@ def test_without_realm():
+ assert 'Digest realm=""' in response.headers['WWW-Authenticate']
+
+
+-@raises(ValueError)
+ def test_invalid_digestfile_1():
+- DigestFileHttpAuthMiddleware(StringIO('u::realm:hash'),
+- wsgi_app=wsgi_app)
++ with pytest.raises(ValueError):
++ DigestFileHttpAuthMiddleware(StringIO('u::realm:hash'),
++ wsgi_app=wsgi_app)
+
+
+-@raises(ValueError)
+ def test_invalid_digestfile_2():
+- DigestFileHttpAuthMiddleware(StringIO('u:realm:hash\nu2:realm2:hash2'),
+- wsgi_app=wsgi_app)
++ with pytest.raises(ValueError):
++ DigestFileHttpAuthMiddleware(StringIO('u:realm:hash\nu2:realm2:hash2'),
++ wsgi_app=wsgi_app)
+
+
+ def test_ticket_1():
diff --git a/dev-python/httpauth/httpauth-0.3-r1.ebuild b/dev-python/httpauth/httpauth-0.3-r1.ebuild
index 703fdd988ecb..ae8ef46058ed 100644
--- a/dev-python/httpauth/httpauth-0.3-r1.ebuild
+++ b/dev-python/httpauth/httpauth-0.3-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
inherit distutils-r1
@@ -16,4 +16,12 @@ LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-distutils_enable_tests nose
+PATCHES=(
+ "${FILESDIR}/${P}-remove-nose-dependency.patch"
+)
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest tests.py
+}