summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/bzip2/Manifest2
-rw-r--r--app-arch/bzip2/bzip2-1.0.6-r11.ebuild118
-rw-r--r--app-arch/bzip2/bzip2-1.0.7-r1.ebuild115
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.4-POSIX-shell.patch21
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.6-CVE-2016-3189.patch18
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.6-mingw.patch27
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.6-nselectors-upper-bound-check.patch30
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.6-out-of-tree-build.patch79
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.6-saneso.patch13
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.6-ubsan-error.patch24
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.7-out-of-tree-build.patch76
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.7-saneso.patch13
12 files changed, 0 insertions, 536 deletions
diff --git a/app-arch/bzip2/Manifest b/app-arch/bzip2/Manifest
index 697d1445ac9e..a4b18f5d5bf2 100644
--- a/app-arch/bzip2/Manifest
+++ b/app-arch/bzip2/Manifest
@@ -1,3 +1 @@
-DIST bzip2-1.0.6.tar.gz 782025 BLAKE2B b31533af7c71d715e6600874bb0a11b9b3aebbb08af0414a6d88bd5a2ad879a482ad408338159cb6c241815da8f48798d2ea7789ea971431d0be42ee827b0a7e SHA512 00ace5438cfa0c577e5f578d8a808613187eff5217c35164ffe044fbafdfec9e98f4192c02a7d67e01e5a5ccced630583ad1003c37697219b0f147343a3fdd12
-DIST bzip2-1.0.7.tar.gz 809680 BLAKE2B da185d9771dd83d59f2c13ea32e9a514ce50c97d69145ca2c4c8f28749fc85c1aec491c5100f4fc6b2183ee397015b7e74a0407dc1d7a360db159a0a3676fd7a SHA512 e0e19b493e6b1f7beeb0eeb0be8a6358c24202173f28acb1e902a768835be9e24f2cb966452fbc90fc3e4e692532ce0c7e86d06aef2d52c0d2a9ac16e12ec8c8
DIST bzip2-1.0.8.tar.gz 810029 BLAKE2B 22ab3acd84f4db8c3d6f59340c252faedfd4447cea00dafbd652e65b6cf8a20adf6835c22e58563004cfafdb15348c924996230b4b23cae42da5e25eeac4bdad SHA512 083f5e675d73f3233c7930ebe20425a533feedeaaa9d8cc86831312a6581cefbe6ed0d08d2fa89be81082f2a5abdabca8b3c080bf97218a1bd59dc118a30b9f3
diff --git a/app-arch/bzip2/bzip2-1.0.6-r11.ebuild b/app-arch/bzip2/bzip2-1.0.6-r11.ebuild
deleted file mode 100644
index 1484da57cb92..000000000000
--- a/app-arch/bzip2/bzip2-1.0.6-r11.ebuild
+++ /dev/null
@@ -1,118 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# XXX: atm, libbz2.a is always PIC :(, so it is always built quickly
-# (since we're building shared libs) ...
-
-EAPI=6
-
-inherit toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="https://sourceware.org/bzip2/"
-SRC_URI="mirror://gentoo/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0/1" # subslot = SONAME
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="static static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- "${FILESDIR}"/${PN}-1.0.6-saneso.patch
- "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- "${FILESDIR}"/${PN}-1.0.6-progress.patch
- "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
- "${FILESDIR}"/${PN}-1.0.6-mingw.patch #393573
- "${FILESDIR}"/${PN}-1.0.6-out-of-tree-build.patch
- "${FILESDIR}"/${PN}-1.0.6-CVE-2016-3189.patch #620466
- "${FILESDIR}"/${PN}-1.0.6-ubsan-error.patch
- "${FILESDIR}"/${PN}-1.0.6-nselectors-upper-bound-check.patch
-)
-
-DOCS=( CHANGES README{,.COMPILATION.PROBLEMS,.XML.STUFF} manual.pdf )
-HTML_DOCS=( manual.html )
-
-src_prepare() {
- default
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s -f :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-}
-
-bemake() {
- emake \
- VPATH="${S}" \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@"
-}
-
-multilib_src_compile() {
- bemake -f "${S}"/Makefile-libbz2_so all
- # Make sure we link against the shared lib #504648
- ln -s libbz2.so.${PV} libbz2.so || die
- bemake -f "${S}"/Makefile all LDFLAGS="${LDFLAGS} $(usex static -static '')"
-}
-
-multilib_src_install() {
- into /usr
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2.so.${PV}
- local v
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /usr/$(get_libdir)/${v}
- done
- use static-libs && dolib.a libbz2.a
-
- if multilib_is_native_abi ; then
- gen_usr_ldscript -a bz2
-
- dobin bzip2recover
- into /
- dobin bzip2
- fi
-}
-
-multilib_src_install_all() {
- # `make install` doesn't cope with out-of-tree builds, nor with
- # installing just non-binaries, so handle things ourselves.
- insinto /usr/include
- doins bzlib.h
- into /usr
- dobin bz{diff,grep,more}
- doman *.1
-
- dosym bzdiff /usr/bin/bzcmp
- dosym bzdiff.1 /usr/share/man/man1/bzcmp.1
-
- dosym bzmore /usr/bin/bzless
- dosym bzmore.1 /usr/share/man/man1/bzless.1
-
- local x
- for x in bunzip2 bzcat bzip2recover ; do
- dosym bzip2.1 /usr/share/man/man1/${x}.1
- done
- for x in bz{e,f}grep ; do
- dosym bzgrep /usr/bin/${x}
- dosym bzgrep.1 /usr/share/man/man1/${x}.1
- done
-
- einstalldocs
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-}
diff --git a/app-arch/bzip2/bzip2-1.0.7-r1.ebuild b/app-arch/bzip2/bzip2-1.0.7-r1.ebuild
deleted file mode 100644
index 37ab7244dad5..000000000000
--- a/app-arch/bzip2/bzip2-1.0.7-r1.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# XXX: atm, libbz2.a is always PIC :(, so it is always built quickly
-# (since we're building shared libs) ...
-
-EAPI=7
-
-inherit toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
-HOMEPAGE="https://sourceware.org/bzip2/"
-SRC_URI="https://sourceware.org/pub/${PN}/${P}.tar.gz"
-
-LICENSE="BZIP2"
-SLOT="0/1" # subslot = SONAME
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="static static-libs"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.0.4-makefile-CFLAGS.patch
- "${FILESDIR}"/${PN}-1.0.7-saneso.patch
- "${FILESDIR}"/${PN}-1.0.4-man-links.patch #172986
- "${FILESDIR}"/${PN}-1.0.6-progress.patch
- "${FILESDIR}"/${PN}-1.0.3-no-test.patch
- "${FILESDIR}"/${PN}-1.0.4-POSIX-shell.patch #193365
- "${FILESDIR}"/${PN}-1.0.6-mingw.patch #393573
- "${FILESDIR}"/${PN}-1.0.7-out-of-tree-build.patch
-)
-
-DOCS=( CHANGES README{,.COMPILATION.PROBLEMS,.XML.STUFF} manual.pdf )
-HTML_DOCS=( manual.html )
-
-src_prepare() {
- default
-
- # - Use right man path
- # - Generate symlinks instead of hardlinks
- # - pass custom variables to control libdir
- sed -i \
- -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' \
- -e 's:ln -s -f $(PREFIX)/bin/:ln -s -f :' \
- -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
- Makefile || die
-}
-
-bemake() {
- emake \
- VPATH="${S}" \
- CC="$(tc-getCC)" \
- AR="$(tc-getAR)" \
- RANLIB="$(tc-getRANLIB)" \
- "$@"
-}
-
-multilib_src_compile() {
- bemake -f "${S}"/Makefile-libbz2_so all
- # Make sure we link against the shared lib #504648
- ln -s libbz2.so.${PV} libbz2.so || die
- bemake -f "${S}"/Makefile all LDFLAGS="${LDFLAGS} $(usex static -static '')"
-}
-
-multilib_src_install() {
- into /usr
-
- # Install the shared lib manually. We install:
- # .x.x.x - standard shared lib behavior
- # .x.x - SONAME some distros use #338321
- # .x - SONAME Gentoo uses
- dolib.so libbz2.so.${PV}
- local v
- for v in libbz2.so{,.{${PV%%.*},${PV%.*}}} ; do
- dosym libbz2.so.${PV} /usr/$(get_libdir)/${v}
- done
- use static-libs && dolib.a libbz2.a
-
- if multilib_is_native_abi ; then
- gen_usr_ldscript -a bz2
-
- dobin bzip2recover
- into /
- dobin bzip2
- fi
-}
-
-multilib_src_install_all() {
- # `make install` doesn't cope with out-of-tree builds, nor with
- # installing just non-binaries, so handle things ourselves.
- insinto /usr/include
- doins bzlib.h
- into /usr
- dobin bz{diff,grep,more}
- doman *.1
-
- dosym bzdiff /usr/bin/bzcmp
- dosym bzdiff.1 /usr/share/man/man1/bzcmp.1
-
- dosym bzmore /usr/bin/bzless
- dosym bzmore.1 /usr/share/man/man1/bzless.1
-
- local x
- for x in bunzip2 bzcat bzip2recover ; do
- dosym bzip2.1 /usr/share/man/man1/${x}.1
- done
- for x in bz{e,f}grep ; do
- dosym bzgrep /usr/bin/${x}
- dosym bzgrep.1 /usr/share/man/man1/${x}.1
- done
-
- einstalldocs
-
- # move "important" bzip2 binaries to /bin and use the shared libbz2.so
- dosym bzip2 /bin/bzcat
- dosym bzip2 /bin/bunzip2
-}
diff --git a/app-arch/bzip2/files/bzip2-1.0.4-POSIX-shell.patch b/app-arch/bzip2/files/bzip2-1.0.4-POSIX-shell.patch
deleted file mode 100644
index 74f8df000b1a..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.4-POSIX-shell.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-bzgrep uses !/bin/sh but then uses the bashism ${var//} so replace those
-with calls to sed so POSIX shells work
-
-http://bugs.gentoo.org/193365
-
---- a/bzgrep
-+++ b/bzgrep
-@@ -63,10 +63,9 @@
- bzip2 -cdfq "$i" | $grep $opt "$pat"
- r=$?
- else
-- j=${i//\\/\\\\}
-- j=${j//|/\\|}
-- j=${j//&/\\&}
-- j=`printf "%s" "$j" | tr '\n' ' '`
-+ # the backslashes here are doubled up as we have to escape each one for the
-+ # shell and then escape each one for the sed expression
-+ j=`printf "%s" "${i}" | sed -e 's:\\\\:\\\\\\\\:g' -e 's:[|]:\\\\|:g' -e 's:[&]:\\\\&:g' | tr '\n' ' '`
- bzip2 -cdfq "$i" | $grep $opt "$pat" | sed "s|^|${j}:|"
- r=$?
- fi
diff --git a/app-arch/bzip2/files/bzip2-1.0.6-CVE-2016-3189.patch b/app-arch/bzip2/files/bzip2-1.0.6-CVE-2016-3189.patch
deleted file mode 100644
index b031c808fef3..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.6-CVE-2016-3189.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-Upstream-Status: Backport
-https://bugzilla.suse.com/attachment.cgi?id=681334
-
-CVE: CVE-2016-3189
-Signed-off-by: Armin Kuster <akuster@mvista.com>
-
-Index: bzip2-1.0.6/bzip2recover.c
-===================================================================
---- a/bzip2recover.c
-+++ b/bzip2recover.c
-@@ -457,6 +457,7 @@ Int32 main ( Int32 argc, Char** argv )
- bsPutUChar ( bsWr, 0x50 ); bsPutUChar ( bsWr, 0x90 );
- bsPutUInt32 ( bsWr, blockCRC );
- bsClose ( bsWr );
-+ outFile = NULL;
- }
- if (wrBlock >= rbCtr) break;
- wrBlock++;
diff --git a/app-arch/bzip2/files/bzip2-1.0.6-mingw.patch b/app-arch/bzip2/files/bzip2-1.0.6-mingw.patch
deleted file mode 100644
index 51469ca4c96e..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.6-mingw.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-make it build for mingw targets
-
-https://bugs.gentoo.org/393573
-
---- a/bzip2.c
-+++ b/bzip2.c
-@@ -129,7 +129,7 @@
- #if BZ_LCCWIN32
- # include <io.h>
- # include <fcntl.h>
--# include <sys\stat.h>
-+# include <sys/stat.h>
-
- # define NORETURN /**/
- # define PATH_SEP '\\'
---- a/bzlib.h
-+++ b/bzlib.h
-@@ -81,6 +81,9 @@ typedef
- /* windows.h define small to char */
- # undef small
- # endif
-+# ifndef WINAPI
-+# define WINAPI
-+# endif
- # ifdef BZ_EXPORT
- # define BZ_API(func) WINAPI func
- # define BZ_EXTERN extern
diff --git a/app-arch/bzip2/files/bzip2-1.0.6-nselectors-upper-bound-check.patch b/app-arch/bzip2/files/bzip2-1.0.6-nselectors-upper-bound-check.patch
deleted file mode 100644
index a7731f7de8f7..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.6-nselectors-upper-bound-check.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 13ca8fee0c897121ae79ae644a212418398dfea7 Mon Sep 17 00:00:00 2001
-From: Amin Hassani <ahassani@chromium.org>
-Date: Fri, 8 Mar 2019 09:58:20 -0800
-Subject: [PATCH] Check for upper bounds of nselectors.
-
-Currently there is no check for the upper bounds of the
-nselectors. Hence, a corrupt input can cause a segfault.
-
-This issue was discovered by one of our fuzzers. The actual error was:
-
-../bzip2-1.0.6/decompress.c:299:10: runtime error: index 18002 out of bounds for type 'UChar [18002]'
----
- decompress.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/decompress.c b/decompress.c
-index 311f566..391552d 100644
---- a/decompress.c
-+++ b/decompress.c
-@@ -288,6 +288,7 @@ Int32 BZ2_decompress ( DState* s )
- if (nGroups < 2 || nGroups > 6) RETURN(BZ_DATA_ERROR);
- GET_BITS(BZ_X_SELECTOR_2, nSelectors, 15);
- if (nSelectors < 1) RETURN(BZ_DATA_ERROR);
-+ if (nSelectors > BZ_MAX_SELECTORS) RETURN(BZ_DATA_ERROR);
- for (i = 0; i < nSelectors; i++) {
- j = 0;
- while (True) {
---
-2.21.0.360.g471c308f928-goog
-
diff --git a/app-arch/bzip2/files/bzip2-1.0.6-out-of-tree-build.patch b/app-arch/bzip2/files/bzip2-1.0.6-out-of-tree-build.patch
deleted file mode 100644
index 806339ebb6b4..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.6-out-of-tree-build.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -53,7 +53,6 @@ libbz2.a: $(OBJS)
-
- check: test
- test: bzip2
-- @cat words1
- ./bzip2 -1 < sample1.ref > sample1.rb2
- ./bzip2 -2 < sample2.ref > sample2.rb2
- ./bzip2 -3 < sample3.ref > sample3.rb2
-@@ -66,7 +65,6 @@ test: bzip2
- cmp sample1.tst sample1.ref
- cmp sample2.tst sample2.ref
- cmp sample3.tst sample3.ref
-- @cat words3
-
- install: bzip2 bzip2recover
- if ( test ! -d $(PREFIX)/bin ) ; then mkdir -p $(PREFIX)/bin ; fi
-@@ -115,25 +113,8 @@ clean:
- sample1.rb2 sample2.rb2 sample3.rb2 \
- sample1.tst sample2.tst sample3.tst
-
--blocksort.o: blocksort.c
-- @cat words0
-- $(CC) $(CFLAGS) -c blocksort.c
--huffman.o: huffman.c
-- $(CC) $(CFLAGS) -c huffman.c
--crctable.o: crctable.c
-- $(CC) $(CFLAGS) -c crctable.c
--randtable.o: randtable.c
-- $(CC) $(CFLAGS) -c randtable.c
--compress.o: compress.c
-- $(CC) $(CFLAGS) -c compress.c
--decompress.o: decompress.c
-- $(CC) $(CFLAGS) -c decompress.c
--bzlib.o: bzlib.c
-- $(CC) $(CFLAGS) -c bzlib.c
--bzip2.o: bzip2.c
-- $(CC) $(CFLAGS) -c bzip2.c
--bzip2recover.o: bzip2recover.c
-- $(CC) $(CFLAGS) -c bzip2recover.c
-+%.o: %.c
-+ $(CC) $(CFLAGS) -c $<
-
-
- distclean: clean
---- a/Makefile-libbz2_so
-+++ b/Makefile-libbz2_so
-@@ -36,9 +36,7 @@ OBJS= blocksort.o \
-
- all: $(OBJS)
- $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.6 $(OBJS)
-- $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.6
-- rm -f libbz2.so.1.0
-- ln -s libbz2.so.1.0.6 libbz2.so.1.0
-+ ln -sf libbz2.so.1.0.6 libbz2.so.1.0
-
- clean:
- rm -f $(OBJS) bzip2.o libbz2.so.1.0.6 libbz2.so.1.0 bzip2-shared
-@@ -43,17 +43,5 @@ all: $(OBJS)
- clean:
- rm -f $(OBJS) bzip2.o libbz2.so.1.0.6 libbz2.so.1.0 bzip2-shared
-
--blocksort.o: blocksort.c
-- $(CC) $(CFLAGS) -c blocksort.c
--huffman.o: huffman.c
-- $(CC) $(CFLAGS) -c huffman.c
--crctable.o: crctable.c
-- $(CC) $(CFLAGS) -c crctable.c
--randtable.o: randtable.c
-- $(CC) $(CFLAGS) -c randtable.c
--compress.o: compress.c
-- $(CC) $(CFLAGS) -c compress.c
--decompress.o: decompress.c
-- $(CC) $(CFLAGS) -c decompress.c
--bzlib.o: bzlib.c
-- $(CC) $(CFLAGS) -c bzlib.c
-+%.o: %.c
-+ $(CC) $(CFLAGS) -c $<
diff --git a/app-arch/bzip2/files/bzip2-1.0.6-saneso.patch b/app-arch/bzip2/files/bzip2-1.0.6-saneso.patch
deleted file mode 100644
index 52ea791ce34a..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.6-saneso.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- a/Makefile-libbz2_so
-+++ b/Makefile-libbz2_so
-@@ -35,8 +35,8 @@
- bzlib.o
-
- all: $(OBJS)
-- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.6 $(OBJS)
-- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.6
-+ $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.6 $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.6
- rm -f libbz2.so.1.0
- ln -s libbz2.so.1.0.6 libbz2.so.1.0
-
diff --git a/app-arch/bzip2/files/bzip2-1.0.6-ubsan-error.patch b/app-arch/bzip2/files/bzip2-1.0.6-ubsan-error.patch
deleted file mode 100644
index 84b811177ed5..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.6-ubsan-error.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-Author: Manoj Gupta <manojgupta@google.com>
-
-Use unsigned 1 for shifting instead of signed 1.
-
-This fixed an issue with shift caught by undefined behavior
-sanitizer in clang.
-bzip2-1.0.6/blocksort.c:255:7
-runtime error: left shift of 1 by 31 places cannot be represented in type 'int'
-
---- a/blocksort.c
-+++ b/blocksort.c
-@@ -202,9 +202,9 @@ void fallbackQSort3 ( UInt32* fmap,
- bhtab [ 0 .. 2+(nblock/32) ] destroyed
- */
-
--#define SET_BH(zz) bhtab[(zz) >> 5] |= (1 << ((zz) & 31))
--#define CLEAR_BH(zz) bhtab[(zz) >> 5] &= ~(1 << ((zz) & 31))
--#define ISSET_BH(zz) (bhtab[(zz) >> 5] & (1 << ((zz) & 31)))
-+#define SET_BH(zz) bhtab[(zz) >> 5] |= (1u << ((zz) & 31))
-+#define CLEAR_BH(zz) bhtab[(zz) >> 5] &= ~(1u << ((zz) & 31))
-+#define ISSET_BH(zz) (bhtab[(zz) >> 5] & (1u << ((zz) & 31)))
- #define WORD_BH(zz) bhtab[(zz) >> 5]
- #define UNALIGNED_BH(zz) ((zz) & 0x01f)
-
diff --git a/app-arch/bzip2/files/bzip2-1.0.7-out-of-tree-build.patch b/app-arch/bzip2/files/bzip2-1.0.7-out-of-tree-build.patch
deleted file mode 100644
index 64cca58eac34..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.7-out-of-tree-build.patch
+++ /dev/null
@@ -1,76 +0,0 @@
---- bzip2-1.0.7/Makefile
-+++ bzip2-1.0.7/Makefile
-@@ -54,7 +54,6 @@
-
- check: test
- test: bzip2
-- @cat words1
- ./bzip2 -1 < sample1.ref > sample1.rb2
- ./bzip2 -2 < sample2.ref > sample2.rb2
- ./bzip2 -3 < sample3.ref > sample3.rb2
-@@ -67,7 +66,6 @@
- cmp sample1.tst sample1.ref
- cmp sample2.tst sample2.ref
- cmp sample3.tst sample3.ref
-- @cat words3
-
- install: bzip2 bzip2recover
- if ( test ! -d $(PREFIX)/bin ) ; then mkdir -p $(PREFIX)/bin ; fi
-@@ -113,25 +111,8 @@
- sample1.rb2 sample2.rb2 sample3.rb2 \
- sample1.tst sample2.tst sample3.tst
-
--blocksort.o: blocksort.c
-- @cat words0
-- $(CC) $(CFLAGS) -c blocksort.c
--huffman.o: huffman.c
-- $(CC) $(CFLAGS) -c huffman.c
--crctable.o: crctable.c
-- $(CC) $(CFLAGS) -c crctable.c
--randtable.o: randtable.c
-- $(CC) $(CFLAGS) -c randtable.c
--compress.o: compress.c
-- $(CC) $(CFLAGS) -c compress.c
--decompress.o: decompress.c
-- $(CC) $(CFLAGS) -c decompress.c
--bzlib.o: bzlib.c
-- $(CC) $(CFLAGS) -c bzlib.c
--bzip2.o: bzip2.c
-- $(CC) $(CFLAGS) -c bzip2.c
--bzip2recover.o: bzip2recover.c
-- $(CC) $(CFLAGS) -c bzip2recover.c
-+%.o: %.c
-+ $(CC) $(CFLAGS) -c $<
-
-
- distclean: clean
---- bzip2-1.0.7/Makefile-libbz2_so
-+++ bzip2-1.0.7/Makefile-libbz2_so
-@@ -36,24 +36,10 @@
-
- all: $(OBJS)
- $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.7 $(OBJS)
-- $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
-- rm -f libbz2.so.1.0
-- ln -s libbz2.so.1.0.7 libbz2.so.1.0
-+ ln -sf libbz2.so.1.0.7 libbz2.so.1.0
-
- clean:
- rm -f $(OBJS) bzip2.o libbz2.so.1.0.7 libbz2.so.1.0 bzip2-shared
-
--blocksort.o: blocksort.c
-- $(CC) $(CFLAGS) -c blocksort.c
--huffman.o: huffman.c
-- $(CC) $(CFLAGS) -c huffman.c
--crctable.o: crctable.c
-- $(CC) $(CFLAGS) -c crctable.c
--randtable.o: randtable.c
-- $(CC) $(CFLAGS) -c randtable.c
--compress.o: compress.c
-- $(CC) $(CFLAGS) -c compress.c
--decompress.o: decompress.c
-- $(CC) $(CFLAGS) -c decompress.c
--bzlib.o: bzlib.c
-- $(CC) $(CFLAGS) -c bzlib.c
-+%.o: %.c
-+ $(CC) $(CFLAGS) -c $<
diff --git a/app-arch/bzip2/files/bzip2-1.0.7-saneso.patch b/app-arch/bzip2/files/bzip2-1.0.7-saneso.patch
deleted file mode 100644
index d63226684f66..000000000000
--- a/app-arch/bzip2/files/bzip2-1.0.7-saneso.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- bzip2-1.0.7/Makefile-libbz2_so
-+++ bzip2-1.0.7/Makefile-libbz2_so
-@@ -35,8 +35,8 @@
- bzlib.o
-
- all: $(OBJS)
-- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.7 $(OBJS)
-- $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
-+ $(CC) $(LDFLAGS) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.7 $(OBJS)
-+ $(CC) $(LDFLAGS) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.7
- rm -f libbz2.so.1.0
- ln -s libbz2.so.1.0.7 libbz2.so.1.0
-